<!DOCTYPE html>
<html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" 
    xmlns:og="http://opengraphprotocol.org/schema/"
    xmlns:fb="http://www.facebook.com/2008/fbml">
<head >
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v18.5.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Once more with feeling: Congressional action on immigration is urgent &ndash; Baptist News Global</title>
	<link rel="canonical" href="https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Once more with feeling: Congressional action on immigration is urgent &ndash; Baptist News Global" />
	<meta property="og:description" content="The coming end to Title 42 restrictions on immigrants is good news, but its demise will highlight the more urgent need for Congress to pass meaningful immigration reform, according to a panel of business, national security and faith leaders. In..." />
	<meta property="og:url" content="https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/" />
	<meta property="og:site_name" content="Baptist News Global" />
	<meta property="article:publisher" content="https://www.facebook.com/BNGbaptistnews/" />
	<meta property="article:published_time" content="2022-04-14T12:32:03+00:00" />
	<meta property="article:modified_time" content="2022-04-14T12:48:00+00:00" />
	<meta property="og:image" content="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP22041141264766.jpg" />
	<meta property="og:image:width" content="2000" />
	<meta property="og:image:height" content="976" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@baptist_news" />
	<meta name="twitter:site" content="@baptist_news" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Jeff Brumley" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="7 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://baptistnews.com/#website","url":"https://baptistnews.com/","name":"Baptist News Global","description":"Conversations that matter","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://baptistnews.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/#primaryimage","inLanguage":"en-US","url":"https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP22041141264766.jpg","contentUrl":"https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP22041141264766.jpg","width":2000,"height":976,"caption":"A mother takes photos of her children leaning on the wall with images of Virgin Guadalupe that divides Mexico from the United States. (Photo by Antonio Cascio / SOPA Images/Sipa USA)(Sipa via AP Images)"},{"@type":"WebPage","@id":"https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/#webpage","url":"https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/","name":"Once more with feeling: Congressional action on immigration is urgent &ndash; Baptist News Global","isPartOf":{"@id":"https://baptistnews.com/#website"},"primaryImageOfPage":{"@id":"https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/#primaryimage"},"datePublished":"2022-04-14T12:32:03+00:00","dateModified":"2022-04-14T12:48:00+00:00","author":{"@id":"https://baptistnews.com/#/schema/person/898b6dda8e0a8c86f64821fc1f66754b"},"breadcrumb":{"@id":"https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/#breadcrumb"},"inLanguage":"en-US","potentialAction":{"@type":"ListenAction","target":"https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/#podcast_player_133803","object":{"@id":"https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/#/schema/podcast"}},"mainEntityOfPage":"https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/#/schema/podcast"},{"@type":"BreadcrumbList","@id":"https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://baptistnews.com/"},{"@type":"ListItem","position":2,"name":"Once more with feeling: Congressional action on immigration is urgent"}]},{"@type":"Person","@id":"https://baptistnews.com/#/schema/person/898b6dda8e0a8c86f64821fc1f66754b","name":"Jeff Brumley","image":{"@type":"ImageObject","@id":"https://baptistnews.com/#personlogo","inLanguage":"en-US","url":"https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/02/jeffmugcropped2014-150x150.jpg","contentUrl":"https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/02/jeffmugcropped2014-150x150.jpg","caption":"Jeff Brumley"},"description":"Jeff Brumley is Senior News Writer for Baptist News Global. A veteran newspaper reporter, he lives in Jacksonville, Fla., with his dog, Nosey.","url":"https://baptistnews.com/article/author/jeff/"},{"@type":["PodcastEpisode","OnDemandEvent"],"@id":"https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/#/schema/podcast","eventAttendanceMode":"https://schema.org/OnlineEventAttendanceMode","location":{"@type":"VirtualLocation","url":"https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/","@id":"https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/#webpage"},"url":"https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/","name":"Once more with feeling: Congressional action on immigration is urgent &ndash; Baptist News Global","datePublished":"2022-04-14","description":"The coming end to Title 42 restrictions on immigrants is good news, but its demise will highlight the more urgent need for Congress to pass meaningful immigration reform, according to a panel of business, national security and faith leaders. In..."}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//a.omappapi.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Baptist News Global &raquo; Feed" href="https://baptistnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Baptist News Global &raquo; Comments Feed" href="https://baptistnews.com/comments/feed/" />
 
    <meta property="og:title" content="Once more with feeling: Congressional action on immigration is urgent"/>
    <meta property="og:type" content="article"/>
    <meta property="og:url" content="https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/"/>
    <meta property="og:site_name" content="Baptist News Global"/>
    <meta property="og:description" content="The coming end to Title 42 restrictions on immigrants is good news, but its demise will highlight the more urgent need for Congress to pass meaningful immigration reform, according to a panel of business, national security and faith leaders.
In a sense, debate over the Trump administration’s cont"/>
    <meta property="og:image" content="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP22041141264766-300x200.jpg"/>
 
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/baptistnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='pt-cv-public-style-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/content-views-query-and-display-post-page/public/assets/css/cv.css?ver=2.4.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='pt-cv-public-pro-style-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/pt-content-views-pro/public/assets/css/cvpro.min.css?ver=5.3.4.3' type='text/css' media='all' />
<link rel='stylesheet' id='baptist-news-global-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/bng/style.css?ver=1.3.13' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.3' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.9.3' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='dgd-scrollbox-plugin-core-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/dreamgrow-scroll-triggered-box/css/style.css?ver=2.3' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_fonts-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/photo-gallery/css/bwg-fonts/fonts.css?ver=0.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='sumoselect-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/photo-gallery/css/sumoselect.min.css?ver=3.3.24' type='text/css' media='all' />
<link rel='stylesheet' id='mCustomScrollbar-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/photo-gallery/css/jquery.mCustomScrollbar.min.css?ver=3.1.5' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_frontend-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/photo-gallery/css/styles.min.css?ver=1.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-frontend-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/wp-user-avatar/assets/css/frontend.min.css?ver=3.2.10' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-flatpickr-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.css?ver=3.2.10' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-select2-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=PT+Sans%3A400%2C700&#038;ver=1.3.13' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-includes/css/dashicons.min.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='fancybox-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/easy-fancybox/css/jquery.fancybox.min.css?ver=1.3.24' type='text/css' media='screen' />
<link rel='stylesheet' id='addthis_all_pages-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.8' type='text/css' media='all' />
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='dgd-scrollbox-plugin-js-extra'>
/* <![CDATA[ */
var $DGD = {"ajaxurl":"\/wp-admin\/admin-ajax.php","nonce":"fa9fc3b603","debug":"","permalink":"https:\/\/baptistnews.com\/article\/once-more-with-feeling-congressional-action-on-immigration-is-urgent\/","title":"Once more with feeling: Congressional action on immigration is urgent","thumbnail":"https:\/\/baptistnews.com\/wp-content\/uploads\/2022\/04\/AP22041141264766.jpg","scripthost":"\/wp-content\/plugins\/dreamgrow-scroll-triggered-box\/","scrollboxes":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/dreamgrow-scroll-triggered-box/js/script.js?ver=2.3' id='dgd-scrollbox-plugin-js'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/photo-gallery/js/jquery.sumoselect.min.js?ver=3.3.24' id='sumoselect-js'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/photo-gallery/js/jquery.mobile.min.js?ver=1.4.5' id='jquery-mobile-js'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/photo-gallery/js/jquery.mCustomScrollbar.concat.min.js?ver=3.1.5' id='mCustomScrollbar-js'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/photo-gallery/js/jquery.fullscreen.min.js?ver=0.6.0' id='jquery-fullscreen-js'></script>
<script type='text/javascript' id='bwg_frontend-js-extra'>
/* <![CDATA[ */
var bwg_objectsL10n = {"bwg_field_required":"field is required.","bwg_mail_validation":"This is not a valid email address.","bwg_search_result":"There are no images matching your search.","bwg_select_tag":"Select Tag","bwg_order_by":"Order By","bwg_search":"Search","bwg_show_ecommerce":"Show Ecommerce","bwg_hide_ecommerce":"Hide Ecommerce","bwg_show_comments":"Show Comments","bwg_hide_comments":"Hide Comments","bwg_restore":"Restore","bwg_maximize":"Maximize","bwg_fullscreen":"Fullscreen","bwg_exit_fullscreen":"Exit Fullscreen","bwg_search_tag":"SEARCH...","bwg_tag_no_match":"No tags found","bwg_all_tags_selected":"All tags selected","bwg_tags_selected":"tags selected","play":"Play","pause":"Pause","is_pro":"","bwg_play":"Play","bwg_pause":"Pause","bwg_hide_info":"Hide info","bwg_show_info":"Show info","bwg_hide_rating":"Hide rating","bwg_show_rating":"Show rating","ok":"Ok","cancel":"Cancel","select_all":"Select all","lazy_load":"0","lazy_loader":"https:\/\/baptistnews.com\/wp-content\/plugins\/photo-gallery\/images\/ajax_loader.png","front_ajax":"0","bwg_tag_see_all":"see all tags","bwg_tag_see_less":"see less tags"};
/* ]]> */
</script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/photo-gallery/js/scripts.min.js?ver=1.6.3' id='bwg_frontend-js'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.js?ver=5.9.3' id='ppress-flatpickr-js'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.js?ver=5.9.3' id='ppress-select2-js'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/bng/js/scripts.js?ver=1.1' id='scripts-js'></script>
<link rel="https://api.w.org/" href="https://baptistnews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://baptistnews.com/wp-json/wp/v2/posts/133803" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://baptistnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://wp.me/paufpE-yO7' />
<link rel="alternate" type="application/json+oembed" href="https://baptistnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbaptistnews.com%2Farticle%2Fonce-more-with-feeling-congressional-action-on-immigration-is-urgent%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://baptistnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbaptistnews.com%2Farticle%2Fonce-more-with-feeling-congressional-action-on-immigration-is-urgent%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.8.18 Professional to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { width:100%; max-width:300px; height:100%; max-height:250px; margin: 0 auto; }
	.g-2 { margin:0px 0px 0px 0px; width:100%; max-width:300px; height:100%; max-height:250px; }
	.g-3 {  width:100%; max-width:300px;  height:100%; max-height:250px; margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->


<link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://baptistnews.com/feed/podcast" />

<style type='text/css'>img#wpstats{display:none}</style>
	<meta name="google-site-verification" content="PYPfrB70kLaaJItEdHxJvD33qWvfNjdZEwb1pqGtfXk" /><link rel="apple-touch-icon" sizes="114x114" href="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/bng/images/bng-icon.png"><meta name="apple-mobile-web-app-title" content="BNG">			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {"passthrough":{"twitter":{"via":"baptist_news"}},"url_transforms":{"shorten":{"twitter":"bitly"}},"shorteners":{"bitly":{}}}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"data_ga_property":"UA-23051708-1","data_ga_social":true,"ui_atversion":"300","data_track_addressbar":true,"ui_508_compliant":true}; } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"AddThis","anonymous_profile_id":"wp-a61dfc099177a9e175c7933fe970b572","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script> <script data-cfasync="false" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56f5a8ef6ff74ba1" async="async"></script><link rel="icon" href="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/05/cropped-bng-icon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/05/cropped-bng-icon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/05/cropped-bng-icon-180x180.png" />
<meta name="msapplication-TileImage" content="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/05/cropped-bng-icon-270x270.png" />
			<style type="text/css" id="pt-cv-custom-style-8725337h94">._self.cvplbd{font-family:'PT Sans', Lato, Helvetica, Arial, sans-serif;color:#000;font-size:1.3em;text-decoration:none;} .h4 a{background-image:none;}.category.exclude-from-home-page{display:none;}</style>
			<style id="sccss">/* Enter Your Custom CSS Here *//*Opinion Statement*/
.opinion .statement {
	font-size: .75em;
	margin-bottom: 1em;
	text-transform:uppercase;
	letter-spacing:.1em;
	font-weight:bold;
	color:#77838c;
	font-family: 'PT Sans', Lato, Helvetica, Arial, sans-serif;
}
.category.projects {color:#BB29BB;}
.pt-cv-title a{background-image:none;}
/*Begin Primary Sidebar Email Signup Widget*/
#custom_html-5{
	background-color:transparent;
	margin-bottom:0;
}
#custom_html-5 .widget-title{
	display:none;
}
/*End Primary Sidebar Email Signup Widget*/
/*Begin Article Sidebar Email Signup Widget*/
#custom_html-6{
	background-color:transparent;
	margin-bottom:0;
}
#custom_html-6 .widget-title{
	display:none;
}
/*End Article Sidebar Email Signup Widget*/
/*Begin Fix Menu/sub-menu disappearing problem*/
.genesis-nav-menu .sub-menu a{
	margin:0;
	padding:0 0 .15em 0;
}
/*End Fix Menu/sub-menu disappearing problem*/
/*
.category-10557 .archive-description h1 {border-bottom:4px solid #BB29BB;}
.category.projects {color:#BB29BB;border-bottom-color:#BB29BB;}
#menu-item-108819 a{border-bottom-color:#BB29BB;}
*/
.shortcode-author-avatars div.author-list .user{text-align:left;margin-bottom:12px;border-bottom:1px solid lightgray;}

img.avatar.avatar-60.wp-user-avatar.wp-user-avatar-60.alignnone.photo{margin-right:15px;border-radius:50px}

span.avatar img{margin:0 15px 15px 0;}

.shortcode-author-avatars div.author-list .user .name{font-size:1.5em;font-family:'PT Sans', Lato, Helvetica, Arial, sans-serif;margin-bottom:10px;color:#000;}

.featured-category{display:contents;margin-bottom:5px;}
div#home-featured-headline h5{border-top:2px solid black;padding-top:10px;margin-top:5px;}
.right-twothirds p.entry-meta{display:inline;padding-right:1em;}

span.pdfprnt-button-title.pdfprnt-button-print-title:before{
  	content: "\f193";
    font-family: 'dashicons';
    font-size: 1.5em;
}
a.pdfprnt-button.pdfprnt-button-print
{
	color:#555 !important;
  	background:none !important;
}
.pdfprnt-buttons.pdfprnt-buttons-post.pdfprnt-bottom-right a{
	color:#555;
}
.pdfprnt-buttons.pdfprnt-buttons-post.pdfprnt-bottom-right{
	width:fit-content;
	float:right;
	border-radius:5px;
	border:1px solid #555;
	padding:0px 10px 0px 0px;
}
.at-below-post.addthis_tool{display:contents;}
div#atstbx{width:fit-content;}
.pdfprnt-buttons.pdfprnt-buttons-post.pdfprnt-bottom-right:hover{
	background-color:#eee;
}</style><style type="text/css" id="wp-custom-css">@media only screen and (max-width: 1200px) {

.single .email-signup {display:inherit !important;}
}</style></head>
<body class="post-template-default single single-post postid-133803 single-format-standard content-sidebar genesis-breadcrumbs-hidden"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.498039215686" /><feFuncG type="table" tableValues="0 0.498039215686" /><feFuncB type="table" tableValues="0 0.498039215686" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.549019607843 0.988235294118" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.717647058824 0.254901960784" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.278431372549" /><feFuncB type="table" tableValues="0.592156862745 0.278431372549" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.647058823529" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.780392156863 1" /><feFuncG type="table" tableValues="0 0.949019607843" /><feFuncB type="table" tableValues="0.352941176471 0.470588235294" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.650980392157 0.403921568627" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.447058823529 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.0980392156863 1" /><feFuncG type="table" tableValues="0 0.662745098039" /><feFuncB type="table" tableValues="0.847058823529 0.419607843137" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg>	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TFWMVR"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-TFWMVR');</script>
	<!-- End Google Tag Manager -->
	<div class="site-container"><header class="site-header"><div class="wrap"><div class="title-area"><a href="/"><img src="/wp-content/themes/bng/images/bng-logo.svg" alt="Baptist News Global" /></a></div><div class="widget-area header-widget-area"><div class="sections-nav"><span>Sections</span></div><nav class="nav-primary" aria-label="Main"><div class="wrap"><ul id="menu-primary-nav" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-16" class="nav-orange menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-16"><a href="https://baptistnews.com/category/news/"><span >News</span></a></li>
<li id="menu-item-119209" class="nav-purple menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119209"><a href="https://baptistnews.com/category/analysis/"><span >Analysis</span></a></li>
<li id="menu-item-17" class="nav-blue menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://baptistnews.com/category/opinion/"><span >Opinion</span></a></li>
<li id="menu-item-15" class="nav-green menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="https://baptistnews.com/category/curated/"><span >Curated</span></a></li>
<li id="menu-item-108819" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-108819"><a href="https://baptistnews.com/projects"><span >Storytelling</span></a>
<ul class="sub-menu">
	<li id="menu-item-109174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-109174"><a href="https://baptistnews.com/projects/faith-justice/"><span >Faith &#038; Justice  ></span></a>
	<ul class="sub-menu">
		<li id="menu-item-109769" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-109769"><a href="https://baptistnews.com/projects/faith-justice/metanoia/"><span >Charleston: Metanoia with Bill Stanfield</span></a></li>
		<li id="menu-item-109175" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-109175"><a href="https://baptistnews.com/projects/faith-justice/family-tree/"><span >Charlotte: QC Family Tree with Greg and Helms Jarrell</span></a></li>
		<li id="menu-item-113781" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113781"><a href="https://baptistnews.com/projects/faith-justice/judge-wendell-griffen/"><span >Little Rock: Judge Wendell Griffen</span></a></li>
		<li id="menu-item-115518" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115518"><a href="https://baptistnews.com/projects/faith-justice/north-carolina-conetoe-farming-justice/"><span >North Carolina: Conetoe</span></a></li>
	</ul>
</li>
	<li id="menu-item-110119" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-110119"><a href="https://baptistnews.com/projects/welcoming-the-stranger/"><span >Welcoming the Stranger ></span></a>
	<ul class="sub-menu">
		<li id="menu-item-110120" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-110120"><a href="https://baptistnews.com/projects/welcoming-the-stranger/lost-boys-of-sudan-st-johns-baptist-charlotte/"><span >Lost Boys of Sudan: St. John’s Baptist Charlotte</span></a></li>
		<li id="menu-item-112469" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112469"><a href="https://baptistnews.com/projects/welcoming-the-stranger/awakening-to-immigrant-justice-myers-park-baptist-church/"><span >Awakening to Immigrant Justice: Myers Park Baptist Church</span></a></li>
		<li id="menu-item-113321" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113321"><a href="https://baptistnews.com/projects/welcoming-the-stranger/hospitality-on-the-corner-gaston-christian-center/"><span >Hospitality on the corner: Gaston Christian Center</span></a></li>
	</ul>
</li>
	<li id="menu-item-110334" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-110334"><a href="https://baptistnews.com/projects/signature-ministries/"><span >Signature Ministries ></span></a>
	<ul class="sub-menu">
		<li id="menu-item-110335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-110335"><a href="https://baptistnews.com/projects/signature-ministries/jake-hall-gospel-gothic-music-and-podcasts/"><span >Jake Hall: Gospel Gothic, Music and Radio</span></a></li>
	</ul>
</li>
	<li id="menu-item-111832" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-111832"><a href="https://baptistnews.com/projects/singing-our-faith/"><span >Singing Our Faith ></span></a>
	<ul class="sub-menu">
		<li id="menu-item-111833" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-111833"><a href="https://baptistnews.com/projects/singing-our-faith/hymns-for-a-lifetime/"><span >Hymns for a Lifetime: Ken Wilson and Knollwood Baptist Church</span></a></li>
		<li id="menu-item-114898" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114898"><a href="https://baptistnews.com/projects/singing-our-faith/norfolk-street-choir/"><span >Norfolk Street Choir</span></a></li>
	</ul>
</li>
	<li id="menu-item-112168" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-112168"><a href="https://baptistnews.com/projects/resilient-rural-america/"><span >Resilient Rural America ></span></a>
	<ul class="sub-menu">
		<li id="menu-item-112169" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112169"><a href="https://baptistnews.com/projects/resilient-rural-america/alabama-perry-county/"><span >Alabama: Perry County</span></a></li>
		<li id="menu-item-112693" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112693"><a href="https://baptistnews.com/projects/resilient-rural-america/texas-hidalgo-county/"><span >Texas: Hidalgo County</span></a></li>
		<li id="menu-item-113637" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113637"><a href="https://baptistnews.com/projects/resilient-rural-america/arkansas-delta/"><span >Arkansas Delta</span></a></li>
		<li id="menu-item-114250" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114250"><a href="https://baptistnews.com/projects/resilient-rural-america/southeast-kentucky/"><span >Southeast Kentucky</span></a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-420" class="nav-gray menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-420"><a href="#more"><span >More</span></a>
<ul class="sub-menu">
	<li id="menu-item-147" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-147"><a href="https://baptistnews.com/more/contact/"><span >Contact</span></a></li>
	<li id="menu-item-148" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-148"><a href="https://baptistnews.com/more/about/"><span >About</span></a></li>
	<li id="menu-item-149" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149"><a href="https://baptistnews.com/donate/"><span >Donate</span></a></li>
	<li id="menu-item-122717" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122717"><a href="https://baptistnews.myplannedgift.org/"><span >Planned Giving</span></a></li>
	<li id="menu-item-32277" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32277"><a href="https://baptistnews.com/letters-to-the-editor/"><span >Letters to the Editor</span></a></li>
	<li id="menu-item-145" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-145"><a href="https://baptistnews.com/more/advertising/"><span >Advertising</span></a></li>
	<li id="menu-item-146" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-146"><a href="https://baptistnews.com/more/classifieds/"><span >Ministry Jobs and More</span></a></li>
	<li id="menu-item-144" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-144"><a href="https://baptistnews.com/more/transitions/"><span >Transitions</span></a></li>
	<li id="menu-item-117555" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117555"><a href="https://mailchi.mp/baptistnews/subscribe"><span >Subscribe</span></a></li>
	<li id="menu-item-118901" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-118901"><a href="https://baptistnews.com/more/guidelines-for-opinion-article-submissions/"><span >Submissions and Permissions</span></a></li>
</ul>
</li>
</ul></div></nav><section id="text-2" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div class="donate-block">
 <a class="button" href="/donate">Donate</a> <a class="button" href="https://baptistnews.us4.list-manage.com/subscribe/post?u=fe721f40103f50684ed42c88b&amp;id=dd0edff639" target="_blank" rel="noopener">Subscribe</a>
</div>
<div class="search-block">
<span>Search</span> <img src="/wp-content/themes/bng/images/icon-search.svg" alt="Search this site" data-lazy-src="/wp-content/themes/bng/images/icon-search.svg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="/wp-content/themes/bng/images/icon-search.svg" alt="Search this site" /></noscript>
</div></div>
		</div></section>
<section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" method="get" action="https://baptistnews.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-1">Search this website</label><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search this website"><input class="search-form-submit" type="submit" value="Search"><meta content="https://baptistnews.com/?s={s}"></form></div></section>
</div></div></header><div class="entry-header-image-mobile"><img width="720" height="400" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP22041141264766-720x400.jpg" class="attachment-topstory-standard size-topstory-standard wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-lazy-src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP22041141264766-720x400.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><div class="thumbnail-credits"><div class="thumbnail-credits-icon">i</div><div class="thumbnail-credits-pop">A mother takes photos of her children leaning on the wall with images of Virgin Guadalupe that divides Mexico from the United States. (Photo by Antonio Cascio / SOPA Images/Sipa USA)(Sipa via AP Images)</div></div></div><div class="site-inner"><div class="content-sidebar-wrap"><h1 class="entry-title">Once more with feeling: Congressional action on immigration is urgent</h1>
<p class="entry-meta list"><a href="https://baptistnews.com/category/news/" class="category news">News</a><a href="https://baptistnews.com/article/author/jeff/" title="Posts by Jeff Brumley" rel="author">Jeff Brumley</a> &nbsp;|&nbsp; April 14, 2022</p><div class="entry-header-image"><img width="1200" height="500" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP22041141264766-1200x500.jpg" class="attachment-post-standard size-post-standard wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-lazy-srcset="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP22041141264766-1200x500.jpg 1200w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP22041141264766-600x250.jpg 600w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP22041141264766-300x125.jpg 300w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-lazy-src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP22041141264766-1200x500.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><div class="thumbnail-credits"><div class="thumbnail-credits-icon">i</div><div class="thumbnail-credits-pop">A mother takes photos of her children leaning on the wall with images of Virgin Guadalupe that divides Mexico from the United States. (Photo by Antonio Cascio / SOPA Images/Sipa USA)(Sipa via AP Images)</div></div></div><main class="content"><article class="post-133803 post type-post status-publish format-standard has-post-thumbnail category-news tag-refugees tag-immigration tag-congress tag-border tag-walter-kim tag-title-42 tag-alliance-for-a-new-immigration-coalition tag-jon-baselice tag-stewart-verdery tag-andy-harvey entry" aria-label="Once more with feeling: Congressional action on immigration is urgent"><header class="entry-header"></header><div class="entry-content"><div class="at-above-post addthis_tool" data-url="https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/"></div><p style="font-weight: 400;"><strong>The coming end to Title 42 restrictions</strong> on immigrants is good news, but its demise will highlight the more urgent need for Congress to pass meaningful immigration reform, according to a panel of business, national security and faith leaders.</p>
<p style="font-weight: 400;">In a sense, debate over the Trump administration’s controversial use of an obscure health provision to drive tens of thousands of refugees from the southern border took attention away from the more basic problems that existed before COVID and will still be there after COVID, speakers said at the April 13 discussion hosted by the Alliance for a New Immigration Coalition, or ANIC.</p>
<p style="font-weight: 400;">There remains an urgent need for Congress to enact meaningful immigration reform that addresses the nation’s economic, humanitarian, spiritual and law enforcement challenges related to migration at the U.S.-Mexico border.</p>
<div id="attachment_133799" style="width: 203px" class="wp-caption alignleft"><img aria-describedby="caption-attachment-133799" class=" wp-image-133799 jetpack-lazy-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/image-4-247x300.jpg" alt width="193" height="234" data-lazy-srcset="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/image-4-247x300.jpg 247w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/image-4.jpg 405w" data-lazy-sizes="(max-width: 193px) 100vw, 193px" data-lazy-src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/image-4-247x300.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img aria-describedby="caption-attachment-133799" class=" wp-image-133799" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/image-4-247x300.jpg" alt="" width="193" height="234" srcset="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/image-4-247x300.jpg 247w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/image-4.jpg 405w" sizes="(max-width: 193px) 100vw, 193px" /></noscript><p id="caption-attachment-133799" class="wp-caption-text">Jon Baselice</p></div>
<p style="font-weight: 400;"><strong>“We are going to be pushing both Congress </strong>and the (Biden) administration to sit down and start working with one another because without it we are going to see these problems persist,” said panelist Jon Baselice, vice president of immigration policy for the U.S. Chamber of Commerce.</p>
<p style="font-weight: 400;">Some of the “problems” he referenced include U.S. labor and food shortages due to insufficient numbers of migrant workers being allowed into the United States.</p>
<p style="font-weight: 400;">The longer Congress refuses to act, the “bigger and harder to solve” the problems will become, he added.</p>
<p style="font-weight: 400;">Baselice was joined on the panel by Stewart Verdery, a member of the Council on National Security and Immigration; Walter Kim, president of the National Association of Evangelicals; and Andy Harvey, chief of police in Pharr, Texas, which is located on the U.S.-Mexico border. The discussion was moderated by Kristie De Peña, vice president for policy and director of immigration at the Niskanen Center, a Washington, D.C., think tank specializing in environmental, civil liberties and immigration reform issues and policy.</p>
<div id="attachment_133801" style="width: 192px" class="wp-caption alignright"><img aria-describedby="caption-attachment-133801" loading="lazy" class=" wp-image-133801 jetpack-lazy-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Kristie-De-Pena--225x300.jpeg" alt width="182" height="243" data-lazy-srcset="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Kristie-De-Pena--225x300.jpeg 225w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Kristie-De-Pena--768x1024.jpeg 768w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Kristie-De-Pena-.jpeg 1000w" data-lazy-sizes="(max-width: 182px) 100vw, 182px" data-lazy-src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Kristie-De-Pena--225x300.jpeg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img aria-describedby="caption-attachment-133801" loading="lazy" class=" wp-image-133801" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Kristie-De-Pena--225x300.jpeg" alt="" width="182" height="243" srcset="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Kristie-De-Pena--225x300.jpeg 225w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Kristie-De-Pena--768x1024.jpeg 768w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Kristie-De-Pena-.jpeg 1000w" sizes="(max-width: 182px) 100vw, 182px" /></noscript><p id="caption-attachment-133801" class="wp-caption-text">Kristie De Pena</p></div>
<p style="font-weight: 400;"><strong>De Peña said the concerns of immigration</strong> advocates have risen since the White House announced earlier this month the termination of Title 42. The policy is scheduled to end May 23, although that decision has been challenged in a recent federal lawsuit filed by Arizona, Louisiana and Missouri.</p>
<p style="font-weight: 400;">Ending Title 42 — while important — will not solve America’s broken immigration system, De Peña said. “Collectively, we are in a moment of heightened need for better border management and reform.”</p>
<p style="font-weight: 400;">That’s a sentiment shared by most Americans, she said, referencing a February <a href="https://immigrationforum.org/article/americans-support-reforms-that-address-border-dreamers-farmworkers/">survey</a> by the National Immigration Forum that found 79% of registered voters, regardless of party affiliation, want lawmakers to engage in bipartisan efforts to improve border security, create pathways to citizenship for undocumented immigrants brought into the country as children, and provide legal avenues for migrant farm hands and other essential workers.</p>
<p style="font-weight: 400;"><strong>“We know Americans are feeling</strong> a lot of this urgency, whether it’s about immigration per se, or it’s about some of the economic concerns, the health care challenges we’re seeing, workforce shortages — these are all tangential immigration issues that we are seeing top of mind for a lot of Americans and businesses,” De Peña said. “We need solutions. The time is now to lead on solutions.”</p>
<div id="attachment_133800" style="width: 202px" class="wp-caption alignleft"><img aria-describedby="caption-attachment-133800" loading="lazy" class=" wp-image-133800 jetpack-lazy-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Stewart-Verdery-2-224x300.jpeg" alt width="192" height="257" data-lazy-srcset="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Stewart-Verdery-2-224x300.jpeg 224w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Stewart-Verdery-2.jpeg 439w" data-lazy-sizes="(max-width: 192px) 100vw, 192px" data-lazy-src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Stewart-Verdery-2-224x300.jpeg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img aria-describedby="caption-attachment-133800" loading="lazy" class=" wp-image-133800" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Stewart-Verdery-2-224x300.jpeg" alt="" width="192" height="257" srcset="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Stewart-Verdery-2-224x300.jpeg 224w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Stewart-Verdery-2.jpeg 439w" sizes="(max-width: 192px) 100vw, 192px" /></noscript><p id="caption-attachment-133800" class="wp-caption-text">Stewart Verdery (Photo by Ian Wagreich )</p></div>
<p style="font-weight: 400;">In the meantime, while Congress stalled, the Trump-era expulsion policy did little to make the nation any safer, said Verdery, who served in the Department of Homeland Security under George W. Bush.</p>
<p style="font-weight: 400;">“Title 42 was a band-aid for our broader inability to build a case management system to deal with people seeking asylum and seeking entry into the United States,” he said. “The current wave of migrants is not trying to sneak in. They are trying to turn themselves in to Customs and Border Protection or to the Border Patrol so they can have an asylum case reviewed. We need a massive infusion of immigration case officers and judges to handle appeals and effective enforcement to make sure people turn up for their hearings.”</p>
<p style="font-weight: 400;"><strong>Designing and implementing</strong> that system will take a major investment by Congress, Verdery said. “I suppose reasonable people can disagree on the exact criteria for mounting a credible asylum claim. I would probably err on the side of limiting those who are primarily economic migrants. But no matter whether you think the approval rate should be 20% or 80%, we have a broken system when both frivolous and meritorious cases take years to be resolved.”</p>
<blockquote>
<p style="font-weight: 400;">“We have a broken system when both frivolous and meritorious cases take years to be resolved.”</p>
</blockquote>
<p style="font-weight: 400;">And the challenges won’t go away just by talking about them, Verdery added. “It’s easy to decry a broken border, but as long as we have a more robust economy than Central American countries, we will see these same images coming across the border and now is the time to try to fix it.”</p>
<div id="attachment_132636" style="width: 195px" class="wp-caption alignleft"><img aria-describedby="caption-attachment-132636" loading="lazy" class=" wp-image-132636 jetpack-lazy-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/Walter-Kim-231x300.jpeg" alt width="185" height="240" data-lazy-srcset="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/Walter-Kim-231x300.jpeg 231w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/Walter-Kim-789x1024.jpeg 789w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/Walter-Kim-1183x1536.jpeg 1183w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/Walter-Kim.jpeg 1200w" data-lazy-sizes="(max-width: 185px) 100vw, 185px" data-lazy-src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/Walter-Kim-231x300.jpeg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img aria-describedby="caption-attachment-132636" loading="lazy" class=" wp-image-132636" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/Walter-Kim-231x300.jpeg" alt="" width="185" height="240" srcset="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/Walter-Kim-231x300.jpeg 231w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/Walter-Kim-789x1024.jpeg 789w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/Walter-Kim-1183x1536.jpeg 1183w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/Walter-Kim.jpeg 1200w" sizes="(max-width: 185px) 100vw, 185px" /></noscript><p id="caption-attachment-132636" class="wp-caption-text">Walter Kim</p></div>
<p style="font-weight: 400;">Kim agreed with conservative religious opponents of uncontrolled immigration that Scripture backs the government’s responsibility to provide a secure border and to block the entry of those who would do harm. But he said Scripture simultaneously calls for compassion in offering refuge to those who are fleeing harm.</p>
<p style="font-weight: 400;">“We certainly see in the Bible that God loves and has a deep concern for the immigrant,” he added. “The issue of immigration repeatedly appears in the Bible along with a deep concern for orphans and widows as people of particular vulnerability. So clearly the Bible has this concern for foreigners living among us. So, there is an urgency as I think about the faith community that this issue of immigration reform is not simply about those residing among us who are other — they are actually us.”</p>
<p style="font-weight: 400;"><strong>Meanwhile, hundreds of thousands</strong> of Dreamers are active, valuable members of churches, Christian colleges and seminaries across the U.S., Kim said. “They contribute richly to the life of the church and academic communities. They’re indispensable. They’re a part of us.”</p>
<p style="font-weight: 400;">Nor does ending Title 42 solve the problem local law enforcement faces along the U.S.-Mexico border, Harvey said. “The possibility of Title 42 ending gives it more [of a] sense of urgency, but it’s been like that. It’s nothing new. We have been screaming at the top of our lungs for something to be done.”</p>
<div id="attachment_133802" style="width: 204px" class="wp-caption alignright"><img aria-describedby="caption-attachment-133802" loading="lazy" class=" wp-image-133802 jetpack-lazy-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Andy-Harvey-252x300.jpeg" alt width="194" height="231" data-lazy-srcset="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Andy-Harvey-252x300.jpeg 252w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Andy-Harvey-859x1024.jpeg 859w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Andy-Harvey.jpeg 960w" data-lazy-sizes="(max-width: 194px) 100vw, 194px" data-lazy-src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Andy-Harvey-252x300.jpeg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img aria-describedby="caption-attachment-133802" loading="lazy" class=" wp-image-133802" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Andy-Harvey-252x300.jpeg" alt="" width="194" height="231" srcset="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Andy-Harvey-252x300.jpeg 252w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Andy-Harvey-859x1024.jpeg 859w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Andy-Harvey.jpeg 960w" sizes="(max-width: 194px) 100vw, 194px" /></noscript><p id="caption-attachment-133802" class="wp-caption-text">Andy Harvey</p></div>
<p style="font-weight: 400;">One concern is for the safety of immigrants who have entered the country illegally and who are afraid to seek help when in danger, the police chief added. “What keeps me up at night is the possibility of something happening in my city and not knowing about it because people are living in fear.”</p>
<p style="font-weight: 400;"><strong>Many in law enforcement see</strong> the lack of immigration reform as a public safety issue, he added. “When people live in fear, people are less safe. In spite of what’s going on in Washington, we still have to deal with the reality of what is going on in our local communities.”</p>
<p style="font-weight: 400;">The most recent significant “immigration reform” bill passed in Congress was the Immigration Reform and Control Act of 1986, which made it illegal to hire or recruit illegal immigrants. President Barack Obama called for major reform but was blocked by then House Speaker Paul Ryan.</p>
<p style="font-weight: 400;">To find a <a href="https://www.pewresearch.org/fact-tank/2015/09/30/how-u-s-immigration-laws-and-rules-have-changed-through-history/">major immigration reform</a> passed by Congress requires looking all the way back, to 1965 and passage of the landmark Immigration and Nationality Act that created a new system favoring family reunification and skilled immigrants, rather than country quotas.</p>
<p>&nbsp;</p>
<p style="font-weight: 400;"><strong><u>Related articles:</u></strong></p>
<p style="font-weight: 400;"><a href="https://baptistnews.com/article/majorities-of-all-americans-want-something-congress-refuses-to-do-meaningful-immigration-reform-now/#.YleRJNPMKNY">Majorities of all Americans want something Congress refuses to do: Meaningful immigration reform now</a></p>
<p style="font-weight: 400;"><a href="https://baptistnews.com/article/once-again-immigration-reform-gets-kicked-to-the-curb-by-senate/#.Yh1LEu7MKNY">Once again, immigration reform gets kicked to the curb by Senate</a></p>
<p style="font-weight: 400;"><a href="https://baptistnews.com/article/conservative-commentator-kristol-says-republicans-should-support-immigration-measures/#.YcARIX3MI64">Conservative commentator Kristol says Republicans should support immigration measures</a></p>
<p style="font-weight: 400;"><a href="https://baptistnews.com/article/new-polling-finds-three-views-on-immigration-democrats-party-loyal-republicans-or-trump-loyal-republicans/#.YQxzANNKiNY">New polling finds three views on immigration: Democrats, party-loyal Republicans or Trump-loyal Republicans</a></p>
<p style="font-weight: 400;"><a href="https://baptistnews.com/article/federal-judges-ruling-against-daca-ignites-faith-leaders-demands-for-congress-to-finally-do-something/#.YQxzZdNKiNY">Federal judge’s ruling against DACA ignites faith leaders’ demands for Congress to finally do something</a></p>
<!-- AddThis Advanced Settings above via filter on the_content --><!-- AddThis Advanced Settings below via filter on the_content --><!-- AddThis Advanced Settings generic via filter on the_content --><!-- AddThis Share Buttons above via filter on the_content --><!-- AddThis Share Buttons below via filter on the_content --><div class="at-below-post addthis_tool" data-url="https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/"></div><!-- AddThis Share Buttons generic via filter on the_content --></div><footer class="entry-footer"><div class="tags-wrapper"><span class="tags-header">Tags:</span><a href="https://baptistnews.com/tag/refugees/" rel="tag">Refugees</a><a href="https://baptistnews.com/tag/immigration/" rel="tag">Immigration</a><a href="https://baptistnews.com/tag/congress/" rel="tag">Congress</a><a href="https://baptistnews.com/tag/border/" rel="tag">border</a><a href="https://baptistnews.com/tag/walter-kim/" rel="tag">Walter Kim</a><a href="https://baptistnews.com/tag/title-42/" rel="tag">Title 42</a><a href="https://baptistnews.com/tag/alliance-for-a-new-immigration-coalition/" rel="tag">Alliance for a New Immigration Coalition</a><a href="https://baptistnews.com/tag/jon-baselice/" rel="tag">Jon Baselice</a><a href="https://baptistnews.com/tag/stewart-verdery/" rel="tag">Stewart Verdery</a><a href="https://baptistnews.com/tag/andy-harvey/" rel="tag">Andy Harvey</a></div><a class="more-by-author" href="https://baptistnews.com/article/author/jeff/"><img data-del="avatar" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/02/jeffmugcropped2014-150x150.jpg" class="avatar pp-user-avatar avatar-50 photo  jetpack-lazy-image" height="50" width="50" data-lazy-src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/02/jeffmugcropped2014-150x150.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-del="avatar" src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/02/jeffmugcropped2014-150x150.jpg' class='avatar pp-user-avatar avatar-50 photo ' height='50' width='50'/></noscript><div class="more-by-author-right"><h6>More by</h6><h5>Jeff Brumley</h5></div></a></footer></article></main> 	<aside class="sidebar sidebar-primary widget-area">
 		<li id="yjxkifanpl-3" class="widget yjxkifanpl"><div class="a-single a-90"><a class="gofollow" data-track="OTAsMCwxLDYw" href="https://www.cbts.edu/programs/"><img src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Central_Ad1_300x250.png" /></a></div></li><li id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- Begin Mailchimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://baptistnews.us4.list-manage.com/subscribe/post?u=fe721f40103f50684ed42c88b&amp;id=dd0edff639" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
	<div class="email-signup">
		<h4>Get <strong><img src="/wp-content/themes/bng/images/icon-bng.svg" data-lazy-src="/wp-content/themes/bng/images/icon-bng.svg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="/wp-content/themes/bng/images/icon-bng.svg" /></noscript>BNG</strong> headlines in your inbox</h4>
	<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_fe721f40103f50684ed42c88b_dd0edff639" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>

<!--End mc_embed_signup-->
</div></li><li id="text-12" class="widget widget_text"><h2 class="widgettitle">BNG dinner will bring together Anthea Butler and Beth Allison Barr for a conversation on race and gender</h2>			<div class="textwidget"><p><img loading="lazy" class="size-medium wp-image-132900 jetpack-lazy-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/BNGDinnerSpeakers-300x115.jpg" alt width="300" height="115" data-lazy-src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/BNGDinnerSpeakers-300x115.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="size-medium wp-image-132900" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/BNGDinnerSpeakers-300x115.jpg" alt="" width="300" height="115" srcset="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/BNGDinnerSpeakers-300x115.jpg 300w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/BNGDinnerSpeakers-1024x392.jpg 1024w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/BNGDinnerSpeakers.jpg 1440w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></p>
<p><strong>Two of the most prominent voices</strong> speaking to the American church about race and gender will appear together at the Baptist News Global dinner during the Cooperative Baptist Fellowship’s General Assembly in Dallas this June. <a href="https://app.etapestry.com/onlineforms/AssociatedBaptistPress/BNGFriends2022Dallas-1.html">Get your tickets now!</a></p>
</div>
		</li>		
		<div class="sidebar-featured">
						<h4 class="upper">Featured</h4>
			<ul class="sidebar-featured-ul">
							    <li class="sidebar-featured-item">
						<a href="https://baptistnews.com/article/ketanji-brown-jacksons-experience-at-the-senate-felt-a-lot-like-being-a-baptist-woman-in-ministry/">
				    								<div class="left-third">
								<img src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/GettyImages-1387348368-300x200.jpg" />
							</div><!--/.left-third-->
				    	<div class="right-twothirds">
					    	<h5>Ketanji Brown Jackson’s experience at the Senate felt a lot like being a Baptist woman in ministry</h5>
					    	<p class="entry-meta"><span class="category opinion">Opinion</span></p>				    	</div><!--/.right-twothirds-->
			    	</a>
			    </li><!--/.sidebar-featured-item-->
							    <li class="sidebar-featured-item">
						<a href="https://baptistnews.com/article/3-million-gift-to-baylor-will-integrate-faith-and-learning-in-honors-college/">
				    								<div class="left-third">
								<img src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2021/05/368749_640-300x200.png" />
							</div><!--/.left-third-->
				    	<div class="right-twothirds">
					    	<h5>$3 million gift to Baylor will integrate faith and learning in Honors College</h5>
					    	<p class="entry-meta"><span class="category news">News</span></p>				    	</div><!--/.right-twothirds-->
			    	</a>
			    </li><!--/.sidebar-featured-item-->
							    <li class="sidebar-featured-item">
						<a href="https://baptistnews.com/article/hello-im-a-recovering-racist/">
				    								<div class="left-third">
								<img src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/GettyImages-130019373-300x200.jpg" />
							</div><!--/.left-third-->
				    	<div class="right-twothirds">
					    	<h5>Hello, I’m a recovering racist</h5>
					    	<p class="entry-meta"><span class="category opinion">Opinion</span></p>				    	</div><!--/.right-twothirds-->
			    	</a>
			    </li><!--/.sidebar-featured-item-->
							    <li class="sidebar-featured-item">
						<a href="https://baptistnews.com/article/covid-holy-week-and-gods-consolations/">
				    								<div class="left-third">
								<img src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/25773417_m-300x200.jpg" />
							</div><!--/.left-third-->
				    	<div class="right-twothirds">
					    	<h5>COVID, Holy Week and God’s consolations</h5>
					    	<p class="entry-meta"><span class="category opinion">Opinion</span></p>				    	</div><!--/.right-twothirds-->
			    	</a>
			    </li><!--/.sidebar-featured-item-->
							</ul><!--/.sidebar-featured-ul-->
					</div><!--/.sidebar-featured-->
<hr />
		<div class="sidebar-curated">
			<h4 class="upper">Curated</h4>
			    <style>
        .rpwe-block ul {
            list-style: none !important;
            margin-left: 0 !important;
            padding-left: 0 !important;
        }

        .rpwe-block li {
            border-bottom: 1px solid #eee;
            margin-bottom: 10px;
            padding-bottom: 10px;
            list-style-type: none;
        }

        .rpwe-block a {
            display: inline !important;
            text-decoration: none;
        }

        .rpwe-block h3 {
            background: none !important;
            clear: none;
            margin-bottom: 0 !important;
            margin-top: 0 !important;
            font-weight: 400;
            font-size: 12px !important;
            line-height: 1.5em;
        }

        .rpwe-thumb {
            border: 1px solid #EEE !important;
            box-shadow: none !important;
            margin: 2px 10px 2px 0;
            padding: 3px !important;
        }

        .rpwe-summary {
            font-size: 12px;
        }

        .rpwe-time {
            color: #bbb;
            font-size: 11px;
        }

        .rpwe-comment {
            color: #bbb;
            font-size: 11px;
            padding-left: 5px;
        }

        .rpwe-alignleft {
            display: inline;
            float: left;
        }

        .rpwe-alignright {
            display: inline;
            float: right;
        }

        .rpwe-aligncenter {
            display: block;
            margin-left: auto;
            margin-right: auto;
        }

        .rpwe-clearfix:before,
        .rpwe-clearfix:after {
            content: "";
            display: table !important;
        }

        .rpwe-clearfix:after {
            clear: both;
        }

        .rpwe-clearfix {
            zoom: 1;
        }
    </style>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://baptistnews.com/article/for-jews-fleeing-ukraine-passover-takes-on-new-meaning/"><img class="rpwe-alignleft rpwe-thumb" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/08/AP-LOGO-98x45.png" alt="For Jews fleeing Ukraine, Passover takes on new meaning" height="45" width="98"></a><h3 class="rpwe-title"><a href="https://baptistnews.com/article/for-jews-fleeing-ukraine-passover-takes-on-new-meaning/" title="Permalink to For Jews fleeing Ukraine, Passover takes on new meaning" rel="bookmark">For Jews fleeing Ukraine, Passover takes on new meaning</a></h3><time class="rpwe-time published" datetime="2022-04-14T11:19:53-04:00">April 14, 2022</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://baptistnews.com/article/maryland-lawmakers-expand-who-can-perform-abortions-after-overriding-governors-veto/"><img class="rpwe-alignleft rpwe-thumb" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/05/NPRLOGO-98x45.jpg" alt="Maryland lawmakers expand who can perform abortions after overriding governor&#8217;s veto" height="45" width="98"></a><h3 class="rpwe-title"><a href="https://baptistnews.com/article/maryland-lawmakers-expand-who-can-perform-abortions-after-overriding-governors-veto/" title="Permalink to Maryland lawmakers expand who can perform abortions after overriding governor&#8217;s veto" rel="bookmark">Maryland lawmakers expand who can perform abortions after overriding governor&#8217;s veto</a></h3><time class="rpwe-time published" datetime="2022-04-14T11:16:50-04:00">April 14, 2022</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://baptistnews.com/article/sikhs-sue-us-marine-corps-over-hair-and-beard-restrictions/"><img class="rpwe-alignleft rpwe-thumb" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2021/02/RNS-BLUE-LOGO-98x45.jpg" alt="Sikhs sue US Marine Corps over hair and beard restrictions" height="45" width="98"></a><h3 class="rpwe-title"><a href="https://baptistnews.com/article/sikhs-sue-us-marine-corps-over-hair-and-beard-restrictions/" title="Permalink to Sikhs sue US Marine Corps over hair and beard restrictions" rel="bookmark">Sikhs sue US Marine Corps over hair and beard restrictions</a></h3><time class="rpwe-time published" datetime="2022-04-14T11:11:56-04:00">April 14, 2022</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://baptistnews.com/article/cuban-pastor-sentenced-to-eight-years-in-prison/"><img class="rpwe-alignleft rpwe-thumb" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/08/BAPTIST-STANDARD-logo-98x45.png" alt="Cuban pastor sentenced to eight years in prison" height="45" width="98"></a><h3 class="rpwe-title"><a href="https://baptistnews.com/article/cuban-pastor-sentenced-to-eight-years-in-prison/" title="Permalink to Cuban pastor sentenced to eight years in prison" rel="bookmark">Cuban pastor sentenced to eight years in prison</a></h3><time class="rpwe-time published" datetime="2022-04-14T11:05:56-04:00">April 14, 2022</time></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ -->		</div>


		<!--	<div class="email-signup">
		<h4>Get <strong><img src="/wp-content/themes/bng/images/icon-bng.svg" />BNG</strong> headlines in your inbox</h4>
		
		<form class="email-signup-form" action="//baptistnews.us4.list-manage.com/subscribe/post?u=fe721f40103f50684ed42c88b&amp;id=dd0edff639" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" target="_blank" novalidate>
			<input type="hidden" name="id" value="4efde2bece">
			<input class="input50" type="text" name="FNAME" id="mce-FNAME" size="25" placeholder="First Name">
			<input class="input50 input50last" type="text" name="LNAME" id="mce-LNAME" size="25" placeholder="Last Name">
			<input type="email" autocapitalize="off" autocorrect="off" name="EMAIL" id="mce-EMAIL" size="25" placeholder="name@example.com">
			
			<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_fe721f40103f50684ed42c88b_dd0edff639" tabindex="-1" value=""></div>
	    <div class="clear">

			<div id="mce-responses" class="clear">
				<div class="response" id="mce-error-response" style="display:none"></div>
				<div class="response" id="mce-success-response" style="display:none"></div>
			</div><!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
						
<!--			<input type="submit" value="Sign up" name="subscribe" id="mc-embedded-subscribe" class="button"></div>

		</form><!--/.email-signup-form-->
		
		<!--<script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js'></script><script type='text/javascript'>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[2]='LNAME';ftypes[2]='text';fnames[14]='MMERGE14';ftypes[14]='text';fnames[15]='MMERGE15';ftypes[15]='text';}(jQuery));var $mcj = jQuery.noConflict(true);</script>-->
		
<!--	</div><!--/.email-signup-->
		</aside><!--/.sidebar-->
	</div></div>	<div class="post-bottom">
		<article class="read-next">
			<div><a href="https://baptistnews.com/article/the-beginnings-of-modern-christian-zionism/"><span class="wrap"><h6>Read Next:</h6><span class="alignleft"><img class="" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP690328021-300x150.jpg" /></span><h2>The beginnings of modern Christian Zionism</h2><p class="entry-meta"><span class="category analysis">Analysis</span>Mitri Raheb</p></span></a></div>		</article><!--/.read-next-->
		
		<div class="related-posts">
			<div class="wrap">
				<h4>More <strong>Articles</strong></h4>
				<ul class="show-only upper xsmall">
					<li class="active" data-tab="all"><a href="#all">All</a></li>
					<li data-tab="news"><a href="#news">News</a></li>
					<li data-tab="opinion"><a href="#opinion">Opinion</a></li>
					<li data-tab="curated"><a href="#curated">Curated</a></li>					
				</ul><!--/.show-only-->
				
				<ul class="related-posts-list posts-all active">
													<li class="clearfix">
						<a href="https://baptistnews.com/article/abuse-case-against-pressler-may-proceed-texas-supreme-court-rules/" title="Abuse case against Pressler may proceed, Texas Supreme Court rules">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2017/12/pressler_stained_glass_horizontal-300x200.jpg" />
							<h3>Abuse case against Pressler may proceed, Texas Supreme Court rules</h3>
							<p class="entry-meta"><span class="category news">News</span>Mark Wingfield</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/" title="Once more with feeling: Congressional action on immigration is urgent">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP22041141264766-300x200.jpg" />
							<h3>Once more with feeling: Congressional action on immigration is urgent</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/lets-consider-the-moral-courage-it-takes-for-some-to-reconnect-with-church-after-the-pandemic/" title="Let’s consider the moral courage it takes for some to reconnect with church after the pandemic">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/lightstock_145497_full_mark_wingfield-300x200.jpg" />
							<h3>Let’s consider the moral courage it takes for some to reconnect with church after the pandemic</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Mark Tidsworth</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/dont-get-used-to-war/" title="Don’t get used to war">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/GettyImages-1163322631-300x200.jpg" />
							<h3>Don’t get used to war</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Paula Mangum Sheridan</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/are-black-people-cursed/" title="Are Black people cursed?">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/noahs-drunkenness-by-james-tissot-c-1896-1902-300x200.jpeg" />
							<h3>Are Black people cursed?</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Charles Holley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/memory-and-mandate-a-meditation-on-maundy-thursday/" title="Memory and mandate: A meditation on Maundy Thursday">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/churchempire-africa-ethiopian-icon-footwashing-300x200.jpg" />
							<h3>Memory and mandate: A meditation on Maundy Thursday</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Ken Sehested</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/just-when-you-think-the-united-methodist-church-breakup-cant-get-any-more-difficult/" title="Just when you think the United Methodist Church breakup can’t get any more difficult …">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/423-WB.jpg-300x200.webp" />
							<h3>Just when you think the United Methodist Church breakup can’t get any more difficult …</h3>
							<p class="entry-meta"><span class="category news">News</span>Cynthia Astle</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/ketanji-brown-jacksons-experience-at-the-senate-felt-a-lot-like-being-a-baptist-woman-in-ministry/" title="Ketanji Brown Jackson’s experience at the Senate felt a lot like being a Baptist woman in ministry">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/GettyImages-1387348368-300x200.jpg" />
							<h3>Ketanji Brown Jackson’s experience at the Senate felt a lot like being a Baptist woman in ministry</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Brianna Childs</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/3-million-gift-to-baylor-will-integrate-faith-and-learning-in-honors-college/" title="$3 million gift to Baylor will integrate faith and learning in Honors College">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2021/05/368749_640-300x200.png" />
							<h3>$3 million gift to Baylor will integrate faith and learning in Honors College</h3>
							<p class="entry-meta"><span class="category news">News</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/hello-im-a-recovering-racist/" title="Hello, I’m a recovering racist">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/GettyImages-130019373-300x200.jpg" />
							<h3>Hello, I’m a recovering racist</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Idelette McVicker</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/baptists-and-other-religious-minorities-already-facing-severe-persecution-in-russian-occupied-portions-of-ukraine/" title="Baptists and other religious minorities already facing severe persecution in Russian-occupied portions of Ukraine">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/277518894_5289457374431357_7706708292995282250_n-300x200.jpg" />
							<h3>Baptists and other religious minorities already facing severe persecution in Russian-occupied portions of Ukraine</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/covid-holy-week-and-gods-consolations/" title="COVID, Holy Week and God’s consolations">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/25773417_m-300x200.jpg" />
							<h3>COVID, Holy Week and God’s consolations</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>James B. Johnson II</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/the-beginnings-of-modern-christian-zionism/" title="The beginnings of modern Christian Zionism">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP690328021-300x200.jpg" />
							<h3>The beginnings of modern Christian Zionism</h3>
							<p class="entry-meta"><span class="category analysis">Analysis</span>Mitri Raheb</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/cbfs-eddie-aldape-works-long-days-to-move-ukrainian-refugees-through-slovakia/" title="CBF’s Eddie Aldape works long days to move Ukrainian refugees through Slovakia">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/mcnarysh-2021_22-q2-comm-photo2.jpg-300x200.webp" />
							<h3>CBF’s Eddie Aldape works long days to move Ukrainian refugees through Slovakia</h3>
							<p class="entry-meta"><span class="category news">News</span>Jennifer Colosimo</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/easter-is-for-those-who-have-been-to-the-cemetery/" title="Easter is for those who have been to the cemetery">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/merlin_204887583_6a04e96f-cc91-4d14-bdde-bfb14e4e2d48-superJumbo-300x200.jpg" />
							<h3>Easter is for those who have been to the cemetery</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Brett Younger</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/video-explores-influence-of-race-ethnicity-and-religion-in-shaping-american-immigration-policies/" title="Video explores influence of race, ethnicity and religion in shaping American immigration policies">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/lbjgetty-300x200.jpg" />
							<h3>Video explores influence of race, ethnicity and religion in shaping American immigration policies</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/its-time-to-do-something-about-the-beast-of-corporate-money-in-politics/" title="It’s time to do something about the beast of corporate money in politics">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/47288952_m-300x200.jpg" />
							<h3>It’s time to do something about the beast of corporate money in politics</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Konrad Waldhauser</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/ministry-jobs-and-more-212/" title="Ministry jobs and more">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/02/ministry-cover-1-300x200.jpg" />
							<h3>Ministry jobs and more</h3>
							<p class="entry-meta"><span class="category news">News</span>Barbara Francis</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/no-we-will-not-take-down-an-article-you-dont-like/" title="No, we will not take down an article you don’t like">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/135834314_m-300x200.jpg" />
							<h3>No, we will not take down an article you don’t like</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Mark Wingfield</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/subterranean-hope-in-ukraine/" title="Subterranean hope in Ukraine">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP22083644742514-300x200.jpg" />
							<h3>Subterranean hope in Ukraine</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Bob Ellis</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/berkeley-school-of-theology-names-endowed-chair-for-j-alfred-smith-sr/" title="Berkeley School of Theology names endowed chair for J. Alfred Smith Sr.">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/image001-300x200.png" />
							<h3>Berkeley School of Theology names endowed chair for J. Alfred Smith Sr.</h3>
							<p class="entry-meta"><span class="category news">News</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/wife-of-vocal-sbc-pastor-claims-suffering-emotional-and-verbal-abuse-was-not-grounds-for-divorce-but-for-greater-hope-in-god/" title="Wife of vocal SBC pastor claims suffering emotional and verbal abuse was not grounds for divorce, but for ‘greater hope’ in God">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/22935891_m-300x200.jpg" />
							<h3>Wife of vocal SBC pastor claims suffering emotional and verbal abuse was not grounds for divorce, but for ‘greater hope’ in God</h3>
							<p class="entry-meta"><span class="category news">News</span>David Bumgardner</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/theres-a-third-candidate-for-sbc-president-you-may-not-have-heard-about/" title="There’s a third candidate for SBC president you may not have heard about">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/46424171334_606d839f09_k-300x200.jpg" />
							<h3>There’s a third candidate for SBC president you may not have heard about</h3>
							<p class="entry-meta"><span class="category news">News</span>Mark Wingfield</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/untamed-the-meaning-of-jesus-in-these-odd-times-finale/" title="Untamed: The meaning of Jesus in these odd times finale">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2021/11/file-20210329-13-raget4-300x200.jpg" />
							<h3>Untamed: The meaning of Jesus in these odd times finale</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Bill Leonard, Senior Columnist</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/ohios-death-penalty-opponents-take-their-case-to-the-court-of-public-opinion/" title="Ohio’s death penalty opponents take their case to the court of public opinion">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/GettyImages-1609762-300x200.jpg" />
							<h3>Ohio’s death penalty opponents take their case to the court of public opinion</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
									</ul><!--/.posts-all-->
				
				<ul class="related-posts-list posts-news">
													<li class="clearfix">
						<a href="https://baptistnews.com/article/abuse-case-against-pressler-may-proceed-texas-supreme-court-rules/" title="Abuse case against Pressler may proceed, Texas Supreme Court rules">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2017/12/pressler_stained_glass_horizontal-300x200.jpg" />
							<h3>Abuse case against Pressler may proceed, Texas Supreme Court rules</h3>
							<p class="entry-meta"><span class="category news">News</span>Mark Wingfield</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/once-more-with-feeling-congressional-action-on-immigration-is-urgent/" title="Once more with feeling: Congressional action on immigration is urgent">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP22041141264766-300x200.jpg" />
							<h3>Once more with feeling: Congressional action on immigration is urgent</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/just-when-you-think-the-united-methodist-church-breakup-cant-get-any-more-difficult/" title="Just when you think the United Methodist Church breakup can’t get any more difficult …">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/423-WB.jpg-300x200.webp" />
							<h3>Just when you think the United Methodist Church breakup can’t get any more difficult …</h3>
							<p class="entry-meta"><span class="category news">News</span>Cynthia Astle</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/3-million-gift-to-baylor-will-integrate-faith-and-learning-in-honors-college/" title="$3 million gift to Baylor will integrate faith and learning in Honors College">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2021/05/368749_640-300x200.png" />
							<h3>$3 million gift to Baylor will integrate faith and learning in Honors College</h3>
							<p class="entry-meta"><span class="category news">News</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/baptists-and-other-religious-minorities-already-facing-severe-persecution-in-russian-occupied-portions-of-ukraine/" title="Baptists and other religious minorities already facing severe persecution in Russian-occupied portions of Ukraine">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/277518894_5289457374431357_7706708292995282250_n-300x200.jpg" />
							<h3>Baptists and other religious minorities already facing severe persecution in Russian-occupied portions of Ukraine</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/cbfs-eddie-aldape-works-long-days-to-move-ukrainian-refugees-through-slovakia/" title="CBF’s Eddie Aldape works long days to move Ukrainian refugees through Slovakia">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/mcnarysh-2021_22-q2-comm-photo2.jpg-300x200.webp" />
							<h3>CBF’s Eddie Aldape works long days to move Ukrainian refugees through Slovakia</h3>
							<p class="entry-meta"><span class="category news">News</span>Jennifer Colosimo</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/video-explores-influence-of-race-ethnicity-and-religion-in-shaping-american-immigration-policies/" title="Video explores influence of race, ethnicity and religion in shaping American immigration policies">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/lbjgetty-300x200.jpg" />
							<h3>Video explores influence of race, ethnicity and religion in shaping American immigration policies</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/ministry-jobs-and-more-212/" title="Ministry jobs and more">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/02/ministry-cover-1-300x200.jpg" />
							<h3>Ministry jobs and more</h3>
							<p class="entry-meta"><span class="category news">News</span>Barbara Francis</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/berkeley-school-of-theology-names-endowed-chair-for-j-alfred-smith-sr/" title="Berkeley School of Theology names endowed chair for J. Alfred Smith Sr.">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/image001-300x200.png" />
							<h3>Berkeley School of Theology names endowed chair for J. Alfred Smith Sr.</h3>
							<p class="entry-meta"><span class="category news">News</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/wife-of-vocal-sbc-pastor-claims-suffering-emotional-and-verbal-abuse-was-not-grounds-for-divorce-but-for-greater-hope-in-god/" title="Wife of vocal SBC pastor claims suffering emotional and verbal abuse was not grounds for divorce, but for ‘greater hope’ in God">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/22935891_m-300x200.jpg" />
							<h3>Wife of vocal SBC pastor claims suffering emotional and verbal abuse was not grounds for divorce, but for ‘greater hope’ in God</h3>
							<p class="entry-meta"><span class="category news">News</span>David Bumgardner</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/theres-a-third-candidate-for-sbc-president-you-may-not-have-heard-about/" title="There’s a third candidate for SBC president you may not have heard about">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/46424171334_606d839f09_k-300x200.jpg" />
							<h3>There’s a third candidate for SBC president you may not have heard about</h3>
							<p class="entry-meta"><span class="category news">News</span>Mark Wingfield</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/ohios-death-penalty-opponents-take-their-case-to-the-court-of-public-opinion/" title="Ohio’s death penalty opponents take their case to the court of public opinion">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/GettyImages-1609762-300x200.jpg" />
							<h3>Ohio’s death penalty opponents take their case to the court of public opinion</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/religious-leaders-appeal-to-american-church-to-see-reawaken-america-tour-as-dangerous-christian-nationalism/" title="Religious leaders appeal to American church to see ReAwaken America tour as dangerous Christian nationalism">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/E-9g-Q2XEAMmuze-300x200.jpeg" />
							<h3>Religious leaders appeal to American church to see ReAwaken America tour as dangerous Christian nationalism</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/sbc-presidency-is-a-three-way-race-again-with-barber-announcement/" title="SBC presidency is a three-way race again with Barber announcement">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/615daca0e78a1.image_-300x200.jpg" />
							<h3>SBC presidency is a three-way race again with Barber announcement</h3>
							<p class="entry-meta"><span class="category news">News</span>Mark Wingfield</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/against-the-odds-the-sbc-is-experiencing-a-double-digit-increase-in-giving/" title="Against the odds, the SBC is experiencing a double-digit increase in giving">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/lightstock_35356_full_mark_wingfield-300x200.jpg" />
							<h3>Against the odds, the SBC is experiencing a double-digit increase in giving</h3>
							<p class="entry-meta"><span class="category news">News</span>Mark Wingfield</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/end-of-title-42-is-popular-with-immigration-advocates-but-no-so-much-with-voters/" title="End of Title 42 is popular with immigration advocates but not so much with voters">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/GettyImages-1358450679-300x200.jpg" />
							<h3>End of Title 42 is popular with immigration advocates but not so much with voters</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/willy-rice-no-longer-a-candidate-for-sbc-presidency/" title="Willy Rice no longer a candidate for SBC presidency">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2021/06/SBC21_075_eb-1024x692-1-300x200.jpg" />
							<h3>Willy Rice no longer a candidate for SBC presidency</h3>
							<p class="entry-meta"><span class="category news">News</span>Mark Wingfield</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/dont-become-complacent-to-the-needs-of-ukrainians-bwaid-leader-urges/" title="Don’t become complacent to the needs of Ukrainians, BWAid leader urges">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/GettyImages-1239768692-300x200.jpg" />
							<h3>Don’t become complacent to the needs of Ukrainians, BWAid leader urges</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/interfaith-center-on-corporate-responsibility-celebrates-50-years-of-faith-based-shareholder-advocacy/" title="Interfaith Center on Corporate Responsibility celebrates 50 years of faith-based shareholder advocacy">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP17082556673260-300x200.jpg" />
							<h3>Interfaith Center on Corporate Responsibility celebrates 50 years of faith-based shareholder advocacy</h3>
							<p class="entry-meta"><span class="category news">News</span>Curtis Ramsey-Lucas</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/smaller-churches-are-both-endangered-and-resilient-panel-reports/" title="Smaller churches are both endangered and resilient, panel reports">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/lightstock_591987_full_mark_wingfield-300x200.jpg" />
							<h3>Smaller churches are both endangered and resilient, panel reports</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/ministry-jobs-and-more-211/" title="Ministry jobs and more">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/02/ministry-cover-1-300x200.jpg" />
							<h3>Ministry jobs and more</h3>
							<p class="entry-meta"><span class="category news">News</span>Barbara Francis</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/as-fired-coachs-case-heads-to-supreme-court-broad-coalition-says-its-his-students-who-were-the-victims-not-the-coach/" title="As fired coach’s case heads to Supreme Court, broad coalition says it’s his students who were the victims, not the coach">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/01/Screen-Shot-2022-01-20-at-9.09.01-PM-300x200.png" />
							<h3>As fired coach’s case heads to Supreme Court, broad coalition says it’s his students who were the victims, not the coach</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/franklin-graham-calls-for-holy-week-cease-fire-in-ukraine-war-but-still-wont-name-putin-as-the-source-of-the-suffering/" title="Franklin Graham calls for Holy Week cease-fire in Ukraine war but still won’t name Putin as the source of the suffering">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/GettyImages-925539392-300x200.jpg" />
							<h3>Franklin Graham calls for Holy Week cease-fire in Ukraine war but still won’t name Putin as the source of the suffering</h3>
							<p class="entry-meta"><span class="category news">News</span>Mark Wingfield</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/ukrainian-seminary-dean-among-those-shot-dead-and-left-on-the-street-by-russian-troops/" title="Ukrainian seminary dean among those shot dead and left on the street by Russian troops">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP22094080231558-300x200.jpg" />
							<h3>Ukrainian seminary dean among those shot dead and left on the street by Russian troops</h3>
							<p class="entry-meta"><span class="category news">News</span>Mark Wingfield</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/in-sunday-sermon-sbc-presidential-candidate-defends-deacon-he-removed-over-past-abusive-behavior/" title="In Sunday sermon, SBC presidential candidate defends deacon he removed over past ‘abusive’ behavior">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/Screen-Shot-2022-04-03-at-8.34.32-PM-300x200.png" />
							<h3>In Sunday sermon, SBC presidential candidate defends deacon he removed over past ‘abusive’ behavior</h3>
							<p class="entry-meta"><span class="category news">News</span>David Bumgardner</p>						</a>
					</li>
									</ul><!--/.posts-news-->

				<ul class="related-posts-list posts-opinion">
													<li class="clearfix">
						<a href="https://baptistnews.com/article/lets-consider-the-moral-courage-it-takes-for-some-to-reconnect-with-church-after-the-pandemic/" title="Let’s consider the moral courage it takes for some to reconnect with church after the pandemic">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/lightstock_145497_full_mark_wingfield-300x200.jpg" />
							<h3>Let’s consider the moral courage it takes for some to reconnect with church after the pandemic</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Mark Tidsworth</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/dont-get-used-to-war/" title="Don’t get used to war">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/GettyImages-1163322631-300x200.jpg" />
							<h3>Don’t get used to war</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Paula Mangum Sheridan</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/are-black-people-cursed/" title="Are Black people cursed?">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/noahs-drunkenness-by-james-tissot-c-1896-1902-300x200.jpeg" />
							<h3>Are Black people cursed?</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Charles Holley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/memory-and-mandate-a-meditation-on-maundy-thursday/" title="Memory and mandate: A meditation on Maundy Thursday">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/churchempire-africa-ethiopian-icon-footwashing-300x200.jpg" />
							<h3>Memory and mandate: A meditation on Maundy Thursday</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Ken Sehested</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/ketanji-brown-jacksons-experience-at-the-senate-felt-a-lot-like-being-a-baptist-woman-in-ministry/" title="Ketanji Brown Jackson’s experience at the Senate felt a lot like being a Baptist woman in ministry">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/GettyImages-1387348368-300x200.jpg" />
							<h3>Ketanji Brown Jackson’s experience at the Senate felt a lot like being a Baptist woman in ministry</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Brianna Childs</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/hello-im-a-recovering-racist/" title="Hello, I’m a recovering racist">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/GettyImages-130019373-300x200.jpg" />
							<h3>Hello, I’m a recovering racist</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Idelette McVicker</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/covid-holy-week-and-gods-consolations/" title="COVID, Holy Week and God’s consolations">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/25773417_m-300x200.jpg" />
							<h3>COVID, Holy Week and God’s consolations</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>James B. Johnson II</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/easter-is-for-those-who-have-been-to-the-cemetery/" title="Easter is for those who have been to the cemetery">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/merlin_204887583_6a04e96f-cc91-4d14-bdde-bfb14e4e2d48-superJumbo-300x200.jpg" />
							<h3>Easter is for those who have been to the cemetery</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Brett Younger</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/its-time-to-do-something-about-the-beast-of-corporate-money-in-politics/" title="It’s time to do something about the beast of corporate money in politics">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/47288952_m-300x200.jpg" />
							<h3>It’s time to do something about the beast of corporate money in politics</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Konrad Waldhauser</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/no-we-will-not-take-down-an-article-you-dont-like/" title="No, we will not take down an article you don’t like">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/135834314_m-300x200.jpg" />
							<h3>No, we will not take down an article you don’t like</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Mark Wingfield</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/subterranean-hope-in-ukraine/" title="Subterranean hope in Ukraine">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/AP22083644742514-300x200.jpg" />
							<h3>Subterranean hope in Ukraine</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Bob Ellis</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/untamed-the-meaning-of-jesus-in-these-odd-times-finale/" title="Untamed: The meaning of Jesus in these odd times finale">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2021/11/file-20210329-13-raget4-300x200.jpg" />
							<h3>Untamed: The meaning of Jesus in these odd times finale</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Bill Leonard, Senior Columnist</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/we-need-more-but-different-churches/" title="We need more but different churches">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/03/shutterstock_1694104252-300x200.jpg" />
							<h3>We need more but different churches</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Patrick Wilson</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/the-futility-of-framing-one-another-as-progressives-and-evangelicals-devils-and-dummies/" title="The futility of framing one another as progressives and evangelicals, devils and dummies">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/130598288_m-300x200.jpg" />
							<h3>The futility of framing one another as progressives and evangelicals, devils and dummies</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Rodney Kennedy</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/i-teach-the-things-republican-legislators-are-trying-to-outlaw-heres-what-we-actually-teach/" title="I teach the things Republican legislators are trying to outlaw; here’s what we actually teach">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/GettyImages-1387134577-300x200.jpg" />
							<h3>I teach the things Republican legislators are trying to outlaw; here’s what we actually teach</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Susan M. Shaw, Senior Columnist</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/dear-willy-rice-were-sorry-to-hear-how-youve-been-treated/" title="Dear Willy Rice: We’re sorry to hear how you’ve been treated">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/130976145_m-300x200.jpg" />
							<h3>Dear Willy Rice: We’re sorry to hear how you’ve been treated</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Maina Mwaura with David Phillips</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/letter-to-the-editor-evangelicals-save-an-unborn-baby-or-save-a-soul/" title="Letter to the editor: Evangelicals — save an unborn baby or save a soul?">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/100709443_m-300x200.jpg" />
							<h3>Letter to the editor: Evangelicals — save an unborn baby or save a soul?</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Letters to the Editor</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/living-in-the-highlight-zone/" title="Living in the highlight zone">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/115582727_m-300x200.jpg" />
							<h3>Living in the highlight zone</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Bob Newell</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/in-the-war-of-words-over-guns-wisdom-is-better-than-weapons-of-war/" title="In the war of words over guns, ‘wisdom is better than weapons of war’">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/47663785_m-300x200.jpg" />
							<h3>In the war of words over guns, ‘wisdom is better than weapons of war’</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Russell Waldrop</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/americans-with-disabilities-face-unemployment-and-poverty-rates-twice-the-national-average/" title="Americans with disabilities face unemployment and poverty rates twice the national average">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/109914973_m-300x200.jpg" />
							<h3>Americans with disabilities face unemployment and poverty rates twice the national average</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Curtis Ramsey-Lucas</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/the-oscars-slap-and-the-scapegoating-of-women/" title="The Oscars slap and the scapegoating of women">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/131386323_m-300x200.jpg" />
							<h3>The Oscars slap and the scapegoating of women</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Jennifer Garcia Bashaw</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/a-christians-guide-to-planet-earth/" title="A Christian’s Guide to Planet Earth">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/42121249_m-300x200.jpg" />
							<h3>A Christian’s Guide to Planet Earth</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Betsy Painter</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/spring-hats-strength-and-sisterlocks/" title="Spring hats, strength and sisterlocks">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/BNG.Hats2022Banner-300x200.jpeg" />
							<h3>Spring hats, strength and sisterlocks</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Phawnda Moore</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/why-i-still-consider-myself-an-evangelical/" title="Why I still consider myself an evangelical">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/SHEF_MSH_VIS_1520-001-300x200.jpg" />
							<h3>Why I still consider myself an evangelical</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Kathy Manis Findley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/10-suggestions-for-welcoming-a-new-pastor/" title="10 suggestions for welcoming a new pastor">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/9114935_m-300x200.jpg" />
							<h3>10 suggestions for welcoming a new pastor</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Barry Howard</p>						</a>
					</li>
									</ul><!--/.posts-opinion-->
				
				<ul class="related-posts-list posts-curated">
													<li class="clearfix">
						<a href="https://baptistnews.com/article/for-jews-fleeing-ukraine-passover-takes-on-new-meaning/" title="For Jews fleeing Ukraine, Passover takes on new meaning">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/08/AP-LOGO-209x200.png" />
							<h3>For Jews fleeing Ukraine, Passover takes on new meaning</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/maryland-lawmakers-expand-who-can-perform-abortions-after-overriding-governors-veto/" title="Maryland lawmakers expand who can perform abortions after overriding governor&#8217;s veto">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/05/NPRLOGO-246x200.jpg" />
							<h3>Maryland lawmakers expand who can perform abortions after overriding governor&#8217;s veto</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/sikhs-sue-us-marine-corps-over-hair-and-beard-restrictions/" title="Sikhs sue US Marine Corps over hair and beard restrictions">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2021/02/RNS-BLUE-LOGO-300x200.jpg" />
							<h3>Sikhs sue US Marine Corps over hair and beard restrictions</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/cuban-pastor-sentenced-to-eight-years-in-prison/" title="Cuban pastor sentenced to eight years in prison">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/08/BAPTIST-STANDARD-logo.png" />
							<h3>Cuban pastor sentenced to eight years in prison</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/faith-prevails-for-lgbtq-charlotteans-even-when-churches-reject-them/" title="Faith prevails for LGBTQ Charlotteans — even when churches reject them">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/The-Charlotte-Observer-LOGO-300x200.jpeg" />
							<h3>Faith prevails for LGBTQ Charlotteans — even when churches reject them</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/world-council-of-churches-faces-calls-to-expel-russian-orthodox-church/" title="World Council of Churches faces calls to expel Russian Orthodox Church">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/07/RNSLOGO-300x200.png" />
							<h3>World Council of Churches faces calls to expel Russian Orthodox Church</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/best-easter-pageant-ever-half-a-century-of-jesus-christ-superstar/" title="Best Easter pageant ever? Half a century of ‘Jesus Christ Superstar’">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/10/New-Coversation-Logo-300x200.jpg" />
							<h3>Best Easter pageant ever? Half a century of ‘Jesus Christ Superstar’</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/aarp-lawyers-join-suit-against-african-methodist-episcopal-church-over-retirement-funds/" title="AARP Lawyers Join Suit Against African Methodist Episcopal Church Over Retirement Funds">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2021/03/Religion-Unplugged-300x200.jpg" />
							<h3>AARP Lawyers Join Suit Against African Methodist Episcopal Church Over Retirement Funds</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/christians-mark-palm-sunday-with-jerusalem-procession/" title="Christians mark Palm Sunday with Jerusalem procession">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/08/AP-LOGO-209x200.png" />
							<h3>Christians mark Palm Sunday with Jerusalem procession</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/disgraced-founding-pastor-brian-houston-feuds-online-with-hillsong-about-his-wifes-future/" title="Disgraced founding pastor Brian Houston feuds online with Hillsong about his wife’s future">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/09/RNS-WHITE.png" />
							<h3>Disgraced founding pastor Brian Houston feuds online with Hillsong about his wife’s future</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/the-most-forgotten-queer-folks-in-the-us-are-fighting-back-against-a-powerful-and-publicly-funded-group-that-discriminates-with-impunity/" title="The most forgotten queer folks in the US are fighting back against a powerful — and publicly funded — group that discriminates with impunity">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2021/04/RELIGION-DISPATCHES-1-290x200.png" />
							<h3>The most forgotten queer folks in the US are fighting back against a powerful — and publicly funded — group that discriminates with impunity</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/islamic-state-morphs-and-grows-in-pakistan-afghanistan/" title="Islamic State morphs and grows in Pakistan, Afghanistan">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/08/AP-LOGO-209x200.png" />
							<h3>Islamic State morphs and grows in Pakistan, Afghanistan</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/war-in-ukraine-is-testing-some-american-evangelicals-support-for-putin-as-a-leader-of-conservative-values/" title="War in Ukraine is testing some American evangelicals’ support for Putin as a leader of conservative values">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/10/New-Coversation-Logo-300x200.jpg" />
							<h3>War in Ukraine is testing some American evangelicals’ support for Putin as a leader of conservative values</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/died-gerald-coates-new-church-movement-pioneer/" title="Died: Gerald Coates, New Church Movement Pioneer">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/02/Christianity-Today-GRAY-logo-300x200.png" />
							<h3>Died: Gerald Coates, New Church Movement Pioneer</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/chicago-churchs-plan-to-fast-from-whiteness-for-lent-gets-pushback/" title="Chicago church’s plan to fast from ‘whiteness’ for Lent gets pushback">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2021/02/RNS-BLUE-LOGO-300x200.jpg" />
							<h3>Chicago church’s plan to fast from ‘whiteness’ for Lent gets pushback</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/repaired-texas-synagogue-reopens-months-after-hostage-crisis/" title="Repaired Texas synagogue reopens months after hostage crisis">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/08/AP-LOGO-209x200.png" />
							<h3>Repaired Texas synagogue reopens months after hostage crisis</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/american-atheists-to-take-a-quieter-approach-to-culture-wars-at-atlanta-meeting/" title="American Atheists to take a quieter approach to culture wars at Atlanta meeting">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/09/RNS-WHITE.png" />
							<h3>American Atheists to take a quieter approach to culture wars at Atlanta meeting</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/alabama-passes-bill-criminalizing-some-healthcare-for-transgender-youth/" title="Alabama passes bill criminalizing some healthcare for transgender youth">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2021/06/REUTERS-LOGO-300x200.jpg" />
							<h3>Alabama passes bill criminalizing some healthcare for transgender youth</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/we-expect-to-win-ayahuasca-churches-vow-to-remain-as-court-case-largely-dismissed/" title="‘We expect to win.’ Ayahuasca churches vow to remain as court case largely dismissed.">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2021/02/RNS-BLUE-LOGO-300x200.jpg" />
							<h3>‘We expect to win.’ Ayahuasca churches vow to remain as court case largely dismissed.</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/rebuffed-privately-influential-rabbis-go-public-with-plea-to-cut-off-american-jewish-funding-of-israeli-extremists/" title="Rebuffed privately, influential rabbis go public with plea to cut off American Jewish funding of Israeli extremists">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2021/08/Jewish-Telegrphic-Agency-JTA-225x200.png" />
							<h3>Rebuffed privately, influential rabbis go public with plea to cut off American Jewish funding of Israeli extremists</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/bucha-evangelical-leader-sees-russian-atrocities-looks-for-gods-hand/" title="Bucha Evangelical Leader Sees Russian Atrocities, Looks for God’s Hand">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2022/02/Christianity-Today-GRAY-logo-300x200.png" />
							<h3>Bucha Evangelical Leader Sees Russian Atrocities, Looks for God’s Hand</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/boston-couple-plans-to-build-citys-1st-holocaust-museum/" title="Boston couple plans to build city’s 1st Holocaust museum">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/08/AP-LOGO-209x200.png" />
							<h3>Boston couple plans to build city’s 1st Holocaust museum</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/catholic-bishops-meet-in-secret-to-discuss-culture-war-issues-what-does-it-mean-for-the-church/" title="Catholic Bishops Meet In Secret To Discuss ‘Culture War’ Issues: What Does It Mean For The Church?">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2021/03/Religion-Unplugged-300x200.jpg" />
							<h3>Catholic Bishops Meet In Secret To Discuss ‘Culture War’ Issues: What Does It Mean For The Church?</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/may-god-make-a-miracle-millions-flee-ukraine-praying-for-wars-end/" title="&#8216;May God Make A Miracle’: Millions Flee Ukraine Praying For War&#8217;s End">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2021/03/Religion-Unplugged-300x200.jpg" />
							<h3>&#8216;May God Make A Miracle’: Millions Flee Ukraine Praying For War&#8217;s End</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/restoration-of-notre-dame-remains-a-challenge/" title="Restoration of Notre Dame remains a challenge">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2021/08/Deutsche-Welle-Logo.gif" />
							<h3>Restoration of Notre Dame remains a challenge</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>BNG staff</p>						</a>
					</li>
									</ul><!--/.posts-curated-->
				
			</div><!--/.wrap-->
		</div><!--/.related-posts-->
	</div><!--/.post-bottom-->
	<footer class="site-footer"><div class="wrap">	<p><img src="/wp-content/themes/bng/images/icon-bng.svg" /></p>
	<h5 class="upper">Conversations that Matter.</h5>
	<p class="upper small">&copy; 2022 Baptist News Global. All rights reserved.</p>
	<p class="small">Want to share a story? We hope you will! Read our republishing, terms of use and privacy policies <a href="/bng-terms-of-use">here</a>.</p>
	
	<ul class="social-links">
		<li class="social-facebook"><a target="_blank" href="https://www.facebook.com/BaptistNewsGlobal/"><svg id="Icon" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 36 35.99"><defs><style>.cls-1{fill:#c2cad1;}</style></defs><title>Facebook</title><path class="cls-1" d="M29,3.7H7A3.66,3.66,0,0,0,3.33,7.36V29.31A3.66,3.66,0,0,0,7,33H19.17V21.13H16.51V17h2.59c0-1.22,0-2.3,0-3.42,0-3.24,2.49-4.18,4.72-4.18h3.77v4.06H25.4A1.24,1.24,0,0,0,24,14.69C24,15.21,24,17,24,17H27.6l-0.29,4H24.08V33H29a3.66,3.66,0,0,0,3.67-3.66V7.36A3.66,3.66,0,0,0,29,3.7Z"/></svg></a></li>
		
		<li class="social-twitter"><a target="_blank" href="https://twitter.com/baptist_news"><svg id="Icon" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 36 35.99"><defs><style>.cls-1{fill:#c2cad1;}</style></defs><title>Twitter</title><path class="cls-1" d="M34.17,8.55a12.47,12.47,0,0,1-3.59,1,6.27,6.27,0,0,0,2.75-3.46,12.48,12.48,0,0,1-4,1.52,6.25,6.25,0,0,0-10.81,4.28,6.31,6.31,0,0,0,.16,1.42A17.74,17.74,0,0,1,5.84,6.76,6.25,6.25,0,0,0,7.77,15.1a6.22,6.22,0,0,1-2.83-.78V14.4a6.25,6.25,0,0,0,5,6.13,6.21,6.21,0,0,1-1.65.22,6.33,6.33,0,0,1-1.18-.11A6.25,6.25,0,0,0,13,25a12.58,12.58,0,0,1-9.25,2.59,17.68,17.68,0,0,0,9.58,2.81c11.49,0,17.77-9.52,17.77-17.77q0-.41,0-0.81A12.72,12.72,0,0,0,34.17,8.55Z"/></svg></a></li>
		
		<li class="social-instagram"><a target="_blank" href="https://www.instagram.com/baptistnews"><svg id="Icon" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 36 35.99"><defs><style>.cls-1{fill:#c2cad1;}</style></defs><title>Instagram</title><path class="cls-1" d="M28.69,3.36H7.08A3.64,3.64,0,0,0,3.44,7V28.87a3.64,3.64,0,0,0,3.64,3.64H28.69a3.64,3.64,0,0,0,3.64-3.64V7A3.64,3.64,0,0,0,28.69,3.36ZM23.83,17.94a6,6,0,1,1-.67-2.73A6,6,0,0,1,23.83,17.94Zm5.25,9.83a1.49,1.49,0,0,1-1.49,1.49H8.32a1.49,1.49,0,0,1-1.49-1.49V15.2H9.29a9,9,0,1,0,17.2,0h2.6V27.77h0Zm0-17.27A1.49,1.49,0,0,1,27.59,12H25.32a1.49,1.49,0,0,1-1.49-1.49V8a1.49,1.49,0,0,1,1-1.41h2.74a1.49,1.49,0,0,1,1.49,1.49V10.5h0Z"/></svg></a></li>

		<!--<li class="social-youtube"><a target="_blank" href="#"><svg id="Icon" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 36 35.99"><defs><style>.cls-1{fill:#c2cad1;}</style></defs><title>YouTube</title><g id="Lozenge"><path class="cls-1" d="M34.53,11.18a7.31,7.31,0,0,0-1.34-3.36A4.84,4.84,0,0,0,29.8,6.39C25.07,6,18,6,18,6h0s-7.1,0-11.83.34A4.84,4.84,0,0,0,2.74,7.82,7.31,7.31,0,0,0,1.4,11.18a51.13,51.13,0,0,0-.34,5.47v2.56a51.13,51.13,0,0,0,.34,5.47A7.31,7.31,0,0,0,2.74,28a5.73,5.73,0,0,0,3.73,1.45C9.18,29.75,18,29.83,18,29.83s7.1,0,11.83-.35A4.84,4.84,0,0,0,33.19,28a7.31,7.31,0,0,0,1.34-3.36,51.19,51.19,0,0,0,.34-5.47V16.65A51.19,51.19,0,0,0,34.53,11.18ZM14.48,22.32v-9.5l9.13,4.77Z"/></g></svg></a></li>-->

		<!-- <li class="social-googleplus"><a target="_blank" href="https://plus.google.com/+ABPnewsUS"><svg id="Icon" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 36 35.99"><defs><style>.cls-1{fill:#c2cad1;}</style></defs><title>Google+</title><path class="cls-1" d="M1.35,21a11.58,11.58,0,0,0,10.78,8.79c8,0.5,12.77-6.65,11.78-13.78H13V20.3h6.3c0,1.66-2.16,3.65-3.82,4.31a8.94,8.94,0,0,1-1.82.5A7.28,7.28,0,0,1,5.83,19a6.93,6.93,0,0,1,5.47-7.8,6.66,6.66,0,0,1,6.14,1.49l3.15-3.15C18.94,7,15.09,6,11.8,6.22A11.91,11.91,0,0,0,1.35,21Zm28.37,0.33V18.16H26.4V16h3.32V12.85h2.16V16H35v2.16H31.87v3.15H29.72Z"/></svg></a></li> -->
		
		<li class="social-linkedin"><a target="_blank" href="https://www.linkedin.com/company/baptist-news-global"><svg id="Icon" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 36 35.99"><defs><style>.cls-1{fill:#c2cad1;}</style></defs><title>LinkedIn</title><path class="cls-1" d="M8.45,5.12A2.44,2.44,0,0,0,5.83,7.65a2.44,2.44,0,0,0,2.59,2.49A2.52,2.52,0,1,0,8.45,5.12ZM6,29h5V12H6V29ZM24.43,12.23c-1.59,0-3.22-.33-5,2.36h-0.1L19.29,12H14.87c0.07,1.41.07,3.52,0.07,5.52V29h5V19.19a3.57,3.57,0,0,1,.2-1.25,2.66,2.66,0,0,1,2.53-1.87c1.81,0,2.53,1.41,2.53,3.48V29h5V18.92C30.18,14.2,27.71,12.23,24.43,12.23Z"/></svg></a></li>
		
		<li class="social-rss"><a target="_blank" href="/feed/"><svg id="Icon" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 36 35.99"><defs><style>.cls-1{fill:#c2cad1;}</style></defs><title>RSS</title><path class="cls-1" d="M5.36,4.61S29.77,3.41,31.7,29.15H26.77s1-18.76-21.41-20.45V4.61Z"/><path class="cls-1" d="M5.36,13.15s14.31-.48,17.08,16H17.51s-0.6-9.74-12.15-11.91V13.15Z"/><path class="cls-1" d="M8,23.88A3.13,3.13,0,1,1,4.91,27,3.13,3.13,0,0,1,8,23.88Z"/></svg></a></li>		
		
	</ul>
	</div></footer></div>	<div style="display:none">
			<div class="grofile-hash-map-86b117b472d06cecdf44ce109b8ed3cc">
		</div>
		</div>
		<script type='text/javascript' id='adrotate-dyngroup-js-extra'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"https:\/\/baptistnews.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.dyngroup.js' id='adrotate-dyngroup-js'></script>
<script type='text/javascript' id='adrotate-clicktracker-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/baptistnews.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js' id='adrotate-clicktracker-js'></script>
<script type='text/javascript' id='pt-cv-content-views-script-js-extra'>
/* <![CDATA[ */
var PT_CV_PUBLIC = {"_prefix":"pt-cv-","page_to_show":"5","_nonce":"bd4d1f1d98","is_admin":"","is_mobile":"","ajaxurl":"https:\/\/baptistnews.com\/wp-admin\/admin-ajax.php","lang":"","loading_image_src":"data:image\/gif;base64,R0lGODlhDwAPALMPAMrKygwMDJOTkz09PZWVla+vr3p6euTk5M7OzuXl5TMzMwAAAJmZmWZmZszMzP\/\/\/yH\/C05FVFNDQVBFMi4wAwEAAAAh+QQFCgAPACwAAAAADwAPAAAEQvDJaZaZOIcV8iQK8VRX4iTYoAwZ4iCYoAjZ4RxejhVNoT+mRGP4cyF4Pp0N98sBGIBMEMOotl6YZ3S61Bmbkm4mAgAh+QQFCgAPACwAAAAADQANAAAENPDJSRSZeA418itN8QiK8BiLITVsFiyBBIoYqnoewAD4xPw9iY4XLGYSjkQR4UAUD45DLwIAIfkEBQoADwAsAAAAAA8ACQAABC\/wyVlamTi3nSdgwFNdhEJgTJoNyoB9ISYoQmdjiZPcj7EYCAeCF1gEDo4Dz2eIAAAh+QQFCgAPACwCAAAADQANAAAEM\/DJBxiYeLKdX3IJZT1FU0iIg2RNKx3OkZVnZ98ToRD4MyiDnkAh6BkNC0MvsAj0kMpHBAAh+QQFCgAPACwGAAAACQAPAAAEMDC59KpFDll73HkAA2wVY5KgiK5b0RRoI6MuzG6EQqCDMlSGheEhUAgqgUUAFRySIgAh+QQFCgAPACwCAAIADQANAAAEM\/DJKZNLND\/kkKaHc3xk+QAMYDKsiaqmZCxGVjSFFCxB1vwy2oOgIDxuucxAMTAJFAJNBAAh+QQFCgAPACwAAAYADwAJAAAEMNAs86q1yaWwwv2Ig0jUZx3OYa4XoRAfwADXoAwfo1+CIjyFRuEho60aSNYlOPxEAAAh+QQFCgAPACwAAAIADQANAAAENPA9s4y8+IUVcqaWJ4qEQozSoAzoIyhCK2NFU2SJk0hNnyEOhKR2AzAAj4Pj4GE4W0bkJQIAOw==","is_mobile_tablet":"","sf_no_post_found":"No posts found."};
var PT_CV_PAGINATION = {"first":"\u00ab","prev":"\u2039","next":"\u203a","last":"\u00bb","goto_first":"Go to first page","goto_prev":"Go to previous page","goto_next":"Go to next page","goto_last":"Go to last page","current_page":"Current page is","goto_page":"Go to page"};
/* ]]> */
</script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/content-views-query-and-display-post-page/public/assets/js/cv.js?ver=2.4.0.5' id='pt-cv-content-views-script-js'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/pt-content-views-pro/public/assets/js/cvpro.min.js?ver=5.3.4.3' id='pt-cv-public-pro-script-js'></script>
<script type='text/javascript' id='ppress-frontend-script-js-extra'>
/* <![CDATA[ */
var pp_ajax_form = {"ajaxurl":"https:\/\/baptistnews.com\/wp-admin\/admin-ajax.php","confirm_delete":"Are you sure?","deleting_text":"Deleting...","deleting_error":"An error occurred. Please try again.","nonce":"c0caea8b43","disable_ajax_form":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/wp-user-avatar/assets/js/frontend.min.js?ver=3.2.10' id='ppress-frontend-script-js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202215' id='grofiles-cards-js'></script>
<script type='text/javascript' id='wpgroho-js-extra'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=10.8' id='wpgroho-js'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-includes/js/hoverIntent.min.js?ver=1.10.2' id='hoverIntent-js'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.10' id='superfish-js'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=3.3.5' id='superfish-args-js'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/wp-gallery-custom-links/wp-gallery-custom-links.js?ver=1.1' id='wp-gallery-custom-links-js-js'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/easy-fancybox/js/jquery.fancybox.min.js?ver=1.3.24' id='jquery-fancybox-js'></script>
<script type='text/javascript' id='jquery-fancybox-js-after'>
var fb_timeout, fb_opts={'overlayShow':true,'hideOnOverlayClick':true,'overlayOpacity':.25,'overlayColor':'#fff','showCloseButton':true,'margin':20,'centerOnScroll':true,'enableEscapeButton':true,'autoScale':true };
if(typeof easy_fancybox_handler==='undefined'){
var easy_fancybox_handler=function(){
jQuery('.nofancybox,a.wp-block-file__button,a.pin-it-button,a[href*="pinterest.com/pin/create"],a[href*="facebook.com/share"],a[href*="twitter.com/share"]').addClass('nolightbox');
/* IMG */
var fb_IMG_select='a[href*=".jpg"]:not(.nolightbox,li.nolightbox>a),area[href*=".jpg"]:not(.nolightbox),a[href*=".jpeg"]:not(.nolightbox,li.nolightbox>a),area[href*=".jpeg"]:not(.nolightbox),a[href*=".png"]:not(.nolightbox,li.nolightbox>a),area[href*=".png"]:not(.nolightbox),a[href*=".gif"]:not(.nolightbox,li.nolightbox>a),area[href*=".gif"]:not(.nolightbox)';
jQuery(fb_IMG_select).addClass('fancybox image');
var fb_IMG_sections=jQuery('.gallery,.wp-block-gallery,.tiled-gallery,.wp-block-jetpack-tiled-gallery');
fb_IMG_sections.each(function(){jQuery(this).find(fb_IMG_select).attr('rel','gallery-'+fb_IMG_sections.index(this));});
jQuery('a.fancybox,area.fancybox,li.fancybox a').each(function(){jQuery(this).fancybox(jQuery.extend({},fb_opts,{'transitionIn':'elastic','transitionOut':'elastic','opacity':false,'hideOnContentClick':true,'titleShow':true,'titlePosition':'over','titleFromAlt':true,'showNavArrows':true,'enableKeyboardNav':true,'cyclic':false}))});};
jQuery('a.fancybox-close').on('click',function(e){e.preventDefault();jQuery.fancybox.close()});
};
var easy_fancybox_auto=function(){setTimeout(function(){jQuery('#fancybox-auto').trigger('click')},1000);};
jQuery(easy_fancybox_handler);jQuery(document).on('post-load',easy_fancybox_handler);
jQuery(easy_fancybox_auto);
</script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/easy-fancybox/js/jquery.easing.min.js?ver=1.4.1' id='jquery-easing-js'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/easy-fancybox/js/jquery.mousewheel.min.js?ver=3.1.13' id='jquery-mousewheel-js'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/intersection-observer.js?minify=false&#038;ver=d9298cd9df65ad92eff12a3a90a1a5b8' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/lazy-images.js?minify=false&#038;ver=a902a338e584591be6603d4879c43367' id='jetpack-lazy-images-js'></script>
<script>(function(d){var s=d.createElement("script");s.type="text/javascript";s.src="https://a.omappapi.com/app/js/api.min.js";s.async=true;s.id="omapi-script";d.getElementsByTagName("head")[0].appendChild(s);})(document);</script>
<!--     ===== START Dreamgrow Scroll Triggered Box 2.3 =====   -->

<div class="dgd_overlay"></div>

<!--     ===== END OF Dreamgrow Scroll Triggered Box 2.3 =====   -->

<!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({groupid:1,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-2').gslider({groupid:2,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-3').gslider({groupid:3,speed:6000,repeat_impressions:'Y'});
}});
</script>
<!-- /AdRotate JS -->

<script src='https://stats.wp.com/e-202215.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.8',blog:'154972450',post:'133803',tz:'-4',srv:'baptistnews.com'} ]);
	_stq.push([ 'clickTrackerInit', '154972450', '133803' ]);
</script>
		<script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":133803,"object_key":"post","object_type":"post","term_ids":[2,98,562,976,3182,15240,15821,17921,17922,17923,17924]};</script>
		</body></html>
