<!DOCTYPE html>
<html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" 
    xmlns:og="http://opengraphprotocol.org/schema/"
    xmlns:fb="http://www.facebook.com/2008/fbml">
<head >
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>What an open door to asylum seekers looks like &ndash; Baptist News Global</title>

<!-- This site is optimized with the Yoast SEO plugin v13.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://baptistnews.com/article/what-an-open-door-to-asylum-seekers-looks-like/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="What an open door to asylum seekers looks like &ndash; Baptist News Global" />
<meta property="og:description" content="A Laredo pastor and his family are hard at work helping others, on both sides of the border." />
<meta property="og:url" content="https://baptistnews.com/article/what-an-open-door-to-asylum-seekers-looks-like/" />
<meta property="og:site_name" content="Baptist News Global" />
<meta property="article:publisher" content="https://www.facebook.com/BNGbaptistnews/" />
<meta property="article:section" content="Curated" />
<meta property="article:published_time" content="2020-02-27T13:50:17+00:00" />
<meta property="og:image" content="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Christian-Century.png" />
<meta property="og:image:secure_url" content="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Christian-Century.png" />
<meta property="og:image:width" content="500" />
<meta property="og:image:height" content="400" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="A Laredo pastor and his family are hard at work helping others, on both sides of the border." />
<meta name="twitter:title" content="What an open door to asylum seekers looks like &ndash; Baptist News Global" />
<meta name="twitter:site" content="@baptist_news" />
<meta name="twitter:image" content="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Christian-Century.png" />
<meta name="twitter:creator" content="@baptist_news" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://baptistnews.com/#website","url":"https://baptistnews.com/","name":"Baptist News Global","inLanguage":"en-US","description":"Conversations that matter","potentialAction":{"@type":"SearchAction","target":"https://baptistnews.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://baptistnews.com/article/what-an-open-door-to-asylum-seekers-looks-like/#primaryimage","inLanguage":"en-US","url":"https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Christian-Century.png","width":500,"height":400},{"@type":"WebPage","@id":"https://baptistnews.com/article/what-an-open-door-to-asylum-seekers-looks-like/#webpage","url":"https://baptistnews.com/article/what-an-open-door-to-asylum-seekers-looks-like/","name":"What an open door to asylum seekers looks like &ndash; Baptist News Global","isPartOf":{"@id":"https://baptistnews.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://baptistnews.com/article/what-an-open-door-to-asylum-seekers-looks-like/#primaryimage"},"datePublished":"2020-02-27T13:50:17+00:00","dateModified":"2020-02-27T13:50:17+00:00","author":{"@id":"https://baptistnews.com/#/schema/person/35508437bfcbf77907b150c2b502ea35"}},{"@type":["Person"],"@id":"https://baptistnews.com/#/schema/person/35508437bfcbf77907b150c2b502ea35","name":"Curated Content","image":{"@type":"ImageObject","@id":"https://baptistnews.com/#authorlogo","inLanguage":"en-US","url":"https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/02/bng-icon-150x150-rev.png","caption":"Curated Content"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//a.opmnstr.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Baptist News Global &raquo; Feed" href="https://baptistnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Baptist News Global &raquo; Comments Feed" href="https://baptistnews.com/comments/feed/" />
 
    <meta property="og:title" content="What an open door to asylum seekers looks like"/>
    <meta property="og:type" content="article"/>
    <meta property="og:url" content="https://baptistnews.com/article/what-an-open-door-to-asylum-seekers-looks-like/"/>
    <meta property="og:site_name" content="Baptist News Global"/>
    <meta property="og:description" content="A Laredo pastor and his family are hard at work helping others, on both sides of the border. "/>
    <meta property="og:image" content="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Christian-Century-300x200.png"/>
 
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/baptistnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='pt-cv-public-style-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/content-views-query-and-display-post-page/public/assets/css/cv.css?ver=2.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='pt-cv-public-pro-style-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/pt-content-views-pro/public/assets/css/cvpro.min.css?ver=5.3.4.3' type='text/css' media='all' />
<link rel='stylesheet' id='baptist-news-global-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/bng/style.css?ver=1.3.13' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='dgd-scrollbox-plugin-core-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/dreamgrow-scroll-triggered-box/css/style.css?ver=2.3' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_fonts-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/photo-gallery/css/bwg-fonts/fonts.css?ver=0.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='sumoselect-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/photo-gallery/css/sumoselect.min.css?ver=3.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='mCustomScrollbar-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/photo-gallery/css/jquery.mCustomScrollbar.min.css?ver=1.5.46' type='text/css' media='all' />
<link rel='stylesheet' id='bwg_frontend-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/photo-gallery/css/styles.min.css?ver=1.5.46' type='text/css' media='all' />
<link rel='stylesheet' id='ssp-frontend-player-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/seriously-simple-podcasting/assets/css/player.css?ver=1.20.12' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=PT+Sans%3A400%2C700&#038;ver=1.3.13' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='author-avatars-widget-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/author-avatars/css/widget.css?ver=1.18' type='text/css' media='all' />
<link rel='stylesheet' id='fancybox-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/easy-fancybox/css/jquery.fancybox.min.css?ver=1.3.24' type='text/css' media='screen' />
<link rel='stylesheet' id='addthis_all_pages-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='author-avatars-shortcode-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/author-avatars/css/shortcode.css?ver=1.18' type='text/css' media='all' />
<link rel='stylesheet' id='sccss_style-css'  href='https://baptistnews.com/?sccss=1&#038;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.2.2' type='text/css' media='all' />
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var $DGD = {"ajaxurl":"\/wp-admin\/admin-ajax.php","nonce":"317fe74d96","debug":"","permalink":"https:\/\/baptistnews.com\/article\/what-an-open-door-to-asylum-seekers-looks-like\/","title":"What an open door to asylum seekers looks like","thumbnail":"https:\/\/baptistnews.com\/wp-content\/uploads\/2020\/02\/Christian-Century.png","scripthost":"\/wp-content\/plugins\/dreamgrow-scroll-triggered-box\/","scrollboxes":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/dreamgrow-scroll-triggered-box/js/script.js?ver=2.3'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/photo-gallery/js/jquery.sumoselect.min.js?ver=3.0.3'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/photo-gallery/js/jquery.mobile.min.js?ver=1.3.2'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/photo-gallery/js/jquery.mCustomScrollbar.concat.min.js?ver=1.5.46'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/photo-gallery/js/jquery.fullscreen-0.4.1.min.js?ver=0.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bwg_objectsL10n = {"bwg_field_required":"field is required.","bwg_mail_validation":"This is not a valid email address.","bwg_search_result":"There are no images matching your search.","bwg_select_tag":"Select Tag","bwg_order_by":"Order By","bwg_search":"Search","bwg_show_ecommerce":"Show Ecommerce","bwg_hide_ecommerce":"Hide Ecommerce","bwg_show_comments":"Show Comments","bwg_hide_comments":"Hide Comments","bwg_restore":"Restore","bwg_maximize":"Maximize","bwg_fullscreen":"Fullscreen","bwg_exit_fullscreen":"Exit Fullscreen","bwg_search_tag":"SEARCH...","bwg_tag_no_match":"No tags found","bwg_all_tags_selected":"All tags selected","bwg_tags_selected":"tags selected","play":"Play","pause":"Pause","is_pro":"","bwg_play":"Play","bwg_pause":"Pause","bwg_hide_info":"Hide info","bwg_show_info":"Show info","bwg_hide_rating":"Hide rating","bwg_show_rating":"Show rating","ok":"Ok","cancel":"Cancel","select_all":"Select all","lazy_load":"0","lazy_loader":"https:\/\/baptistnews.com\/wp-content\/plugins\/photo-gallery\/images\/ajax_loader.png","front_ajax":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/photo-gallery/js/scripts.min.js?ver=1.5.46'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/bng/js/scripts.js?ver=1.1'></script>
<script type='text/javascript' data-cfasync="false" id="omapi-script" async="async" src='https://a.opmnstr.com/app/js/api.min.js'></script>
<link rel='https://api.w.org/' href='https://baptistnews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://baptistnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://wp.me/paufpE-uDZ' />
<link rel="alternate" type="application/json+oembed" href="https://baptistnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbaptistnews.com%2Farticle%2Fwhat-an-open-door-to-asylum-seekers-looks-like%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://baptistnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbaptistnews.com%2Farticle%2Fwhat-an-open-door-to-asylum-seekers-looks-like%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.7 to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { width:100%; max-width:300px; height:100%; max-height:250px; margin: 0 auto; }
	.g-2 { margin:0px;  width:100%; max-width:125px; height:100%; max-height:125px; }
	.g-3 { width:100%; max-width:300px; height:100%; max-height:250px; margin: 0 auto; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->


<link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="https://baptistnews.com/feed/podcast" />


<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><meta name="google-site-verification" content="PYPfrB70kLaaJItEdHxJvD33qWvfNjdZEwb1pqGtfXk" /><link rel="apple-touch-icon" sizes="114x114" href="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/bng/images/bng-icon.png"><meta name="apple-mobile-web-app-title" content="BNG">			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {"passthrough":{"twitter":{"via":"baptist_news"}},"url_transforms":{"shorten":{"twitter":"bitly"}},"shorteners":{"bitly":{}}}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"data_ga_property":"UA-23051708-1","data_ga_social":true,"ui_atversion":"300","data_track_addressbar":true,"ui_508_compliant":true}; } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"AddThis","anonymous_profile_id":"wp-a61dfc099177a9e175c7933fe970b572","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script> <script data-cfasync="false" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56f5a8ef6ff74ba1" async="async"></script><link rel="icon" href="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/05/cropped-bng-icon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/05/cropped-bng-icon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/05/cropped-bng-icon-180x180.png" />
<meta name="msapplication-TileImage" content="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/05/cropped-bng-icon-270x270.png" />
			<style type="text/css" id="pt-cv-custom-style-1189dbcdn5">._self.cvplbd{font-family:'PT Sans', Lato, Helvetica, Arial, sans-serif;color:#000;font-size:1.3em;text-decoration:none;} .h4 a{background-image:none;}.category.exclude-from-home-page{display:none;}</style>
						<style type="text/css" id="wp-custom-css">
				@media only screen and (max-width: 1200px) {

.single .email-signup {display:inherit !important;}
}			</style>
		</head>
<body class="post-template-default single single-post postid-117799 single-format-standard content-sidebar genesis-breadcrumbs-hidden">	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TFWMVR"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-TFWMVR');</script>
	<!-- End Google Tag Manager -->
	<div class="site-container"><header class="site-header"><div class="wrap"><div class="title-area"><a href="/"><img src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/bng/images/bng-logo.svg" alt="Baptist News Global" /></a></div><div class="widget-area header-widget-area"><div class="sections-nav"><span>Sections</span></div><nav class="nav-primary" aria-label="Main"><div class="wrap"><ul id="menu-primary-nav" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-16" class="nav-orange menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://baptistnews.com/category/news/"><span >News</span></a></li>
<li id="menu-item-17" class="nav-blue menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17"><a href="https://baptistnews.com/category/opinion/"><span >Opinion</span></a></li>
<li id="menu-item-15" class="nav-green menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15"><a href="https://baptistnews.com/category/curated/"><span >Curated</span></a></li>
<li id="menu-item-108819" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-108819"><a href="https://baptistnews.com/projects"><span >Storytelling</span></a>
<ul class="sub-menu">
	<li id="menu-item-109174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-109174"><a href="https://baptistnews.com/projects/faith-justice/"><span >Faith &#038; Justice  ></span></a>
	<ul class="sub-menu">
		<li id="menu-item-109769" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-109769"><a href="https://baptistnews.com/projects/faith-justice/metanoia/"><span >Charleston: Metanoia with Bill Stanfield</span></a></li>
		<li id="menu-item-109175" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-109175"><a href="https://baptistnews.com/projects/faith-justice/family-tree/"><span >Charlotte: QC Family Tree with Greg and Helms Jarrell</span></a></li>
		<li id="menu-item-113781" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113781"><a href="https://baptistnews.com/projects/faith-justice/judge-wendell-griffen/"><span >Little Rock: Judge Wendell Griffen</span></a></li>
		<li id="menu-item-115518" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115518"><a href="https://baptistnews.com/projects/faith-justice/north-carolina-conetoe-farming-justice/"><span >North Carolina: Conetoe</span></a></li>
	</ul>
</li>
	<li id="menu-item-110119" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-110119"><a href="https://baptistnews.com/projects/welcoming-the-stranger/"><span >Welcoming the Stranger ></span></a>
	<ul class="sub-menu">
		<li id="menu-item-110120" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-110120"><a href="https://baptistnews.com/projects/welcoming-the-stranger/lost-boys-of-sudan-st-johns-baptist-charlotte/"><span >Lost Boys of Sudan: St. John&#8217;s Baptist Charlotte</span></a></li>
		<li id="menu-item-112469" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112469"><a href="https://baptistnews.com/projects/welcoming-the-stranger/awakening-to-immigrant-justice-myers-park-baptist-church/"><span >Awakening to Immigrant Justice: Myers Park Baptist Church</span></a></li>
		<li id="menu-item-113321" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113321"><a href="https://baptistnews.com/projects/welcoming-the-stranger/hospitality-on-the-corner-gaston-christian-center/"><span >Hospitality on the corner: Gaston Christian Center</span></a></li>
	</ul>
</li>
	<li id="menu-item-110334" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-110334"><a href="https://baptistnews.com/projects/signature-ministries/"><span >Signature Ministries ></span></a>
	<ul class="sub-menu">
		<li id="menu-item-110335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-110335"><a href="https://baptistnews.com/projects/signature-ministries/jake-hall-gospel-gothic-music-and-podcasts/"><span >Jake Hall: Gospel Gothic, Music and Radio</span></a></li>
	</ul>
</li>
	<li id="menu-item-111832" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-111832"><a href="https://baptistnews.com/projects/singing-our-faith/"><span >Singing Our Faith ></span></a>
	<ul class="sub-menu">
		<li id="menu-item-111833" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-111833"><a href="https://baptistnews.com/projects/singing-our-faith/hymns-for-a-lifetime/"><span >Hymns for a Lifetime: Ken Wilson and Knollwood Baptist Church</span></a></li>
		<li id="menu-item-114898" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114898"><a href="https://baptistnews.com/projects/singing-our-faith/norfolk-street-choir/"><span >Norfolk Street Choir</span></a></li>
	</ul>
</li>
	<li id="menu-item-112168" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-112168"><a href="https://baptistnews.com/projects/resilient-rural-america/"><span >Resilient Rural America ></span></a>
	<ul class="sub-menu">
		<li id="menu-item-112169" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112169"><a href="https://baptistnews.com/projects/resilient-rural-america/alabama-perry-county/"><span >Alabama: Perry County</span></a></li>
		<li id="menu-item-112693" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112693"><a href="https://baptistnews.com/projects/resilient-rural-america/texas-hidalgo-county/"><span >Texas: Hidalgo County</span></a></li>
		<li id="menu-item-113637" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113637"><a href="https://baptistnews.com/projects/resilient-rural-america/arkansas-delta/"><span >Arkansas Delta</span></a></li>
		<li id="menu-item-114250" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114250"><a href="https://baptistnews.com/projects/resilient-rural-america/southeast-kentucky/"><span >Southeast Kentucky</span></a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-420" class="nav-gray menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-420"><a href="#more"><span >More</span></a>
<ul class="sub-menu">
	<li id="menu-item-147" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-147"><a href="https://baptistnews.com/more/contact/"><span >Contact</span></a></li>
	<li id="menu-item-148" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-148"><a href="https://baptistnews.com/more/about/"><span >About</span></a></li>
	<li id="menu-item-149" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149"><a href="https://baptistnews.com/donate/"><span >Donate</span></a></li>
	<li id="menu-item-32277" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32277"><a href="https://baptistnews.com/letters-to-the-editor/"><span >Letters to the Editor</span></a></li>
	<li id="menu-item-145" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-145"><a href="https://baptistnews.com/more/advertising/"><span >Advertising</span></a></li>
	<li id="menu-item-146" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-146"><a href="https://baptistnews.com/more/classifieds/"><span >Ministry Jobs and More</span></a></li>
	<li id="menu-item-144" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-144"><a href="https://baptistnews.com/more/transitions/"><span >Transitions</span></a></li>
	<li id="menu-item-117555" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117555"><a href="https://mailchi.mp/baptistnews/subscribe"><span >Subscribe</span></a></li>
</ul>
</li>
</ul></div></nav><section id="text-2" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><div class="donate-block">
Support independent, faith-based journalism. <a class="button" href="/donate">Donate</a>
</div>
<div class="search-block">
<span>Search</span> <img src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/bng/images/icon-search.svg" alt="Search this site" data-lazy-src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/bng/images/icon-search.svg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/bng/images/icon-search.svg" alt="Search this site" /></noscript>
</div></div>
		</div></section>
<section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" method="get" action="https://baptistnews.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-1">Search this website</label><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search this website"><input class="search-form-submit" type="submit" value="Search"><meta content="https://baptistnews.com/?s={s}"></form></div></section>
</div></div></header><div class="entry-header-image-mobile"></div><div class="site-inner"><div class="content-sidebar-wrap"><h1 class="entry-title">What an open door to asylum seekers looks like</h1>
<p class="entry-meta list"><a href="https://baptistnews.com/category/curated/" class="category curated">Curated</a><a href="https://www.christiancentury.org/article/features/what-open-door-asylum-seekers-looks">The Christian Century</a> &nbsp;|&nbsp; February 27, 2020</p><main class="content"><article class="post-117799 post type-post status-publish format-standard has-post-thumbnail category-curated entry"><header class="entry-header"></header><div class="entry-content"><div class="curated-readstory"><strong>Read the full story: <a href="https://www.christiancentury.org/article/features/what-open-door-asylum-seekers-looks">The Christian Century</strong></a></div><div class="at-above-post addthis_tool" data-url="https://baptistnews.com/article/what-an-open-door-to-asylum-seekers-looks-like/"></div><p><span style="color: #000000; font-family: Times New Roman;"><img class="alignleft wp-image-117797 size-thumbnail jetpack-lazy-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Christian-Century-150x150.png" alt width="150" height="150" data-lazy-srcset="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Christian-Century-150x150.png 150w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Christian-Century-45x45.png 45w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Christian-Century-150x150.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="alignleft wp-image-117797 size-thumbnail" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Christian-Century-150x150.png" alt="" width="150" height="150" srcset="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Christian-Century-150x150.png 150w, https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Christian-Century-45x45.png 45w" sizes="(max-width: 150px) 100vw, 150px" /></noscript>A Laredo pastor and his family are hard at work helping others, on both sides of the border. </span></p>
<!-- AddThis Advanced Settings above via filter on the_content --><!-- AddThis Advanced Settings below via filter on the_content --><!-- AddThis Advanced Settings generic via filter on the_content --><!-- AddThis Share Buttons above via filter on the_content --><!-- AddThis Share Buttons below via filter on the_content --><div class="at-below-post addthis_tool" data-url="https://baptistnews.com/article/what-an-open-door-to-asylum-seekers-looks-like/"></div><!-- AddThis Share Buttons generic via filter on the_content --></div><footer class="entry-footer"></footer></article></main> 	<aside class="sidebar sidebar-primary widget-area">
 		<li id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- Begin Mailchimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://baptistnews.us4.list-manage.com/subscribe/post?u=fe721f40103f50684ed42c88b&amp;id=dd0edff639" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
	<div class="email-signup">
		<h4>Get <strong><img src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/bng/images/icon-bng.svg" data-lazy-src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/bng/images/icon-bng.svg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/bng/images/icon-bng.svg" /></noscript>BNG</strong> headlines in your inbox</h4>
	<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_fe721f40103f50684ed42c88b_dd0edff639" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>

<!--End mc_embed_signup--></div></li><li id="adrotate_widgets-4" class="widget adrotate_widgets"><div class="g g-3"><div class="g-dyn a-26 c-1"><a href="http://d365.org/"><img src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2017/03/JTC-1.jpg" /></a></div></div></li><li id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><h3><a href="https://baptistnews.com/projects/">Embracing the power of story</a></h3>
Our <b>Storytelling Projects</b> are purposefully situated at those intersections where life and faith meet – and sometimes collide. We explore some of the big questions, complex issues and daunting challenges that are part of living faithfully in our time and space. Be inspired by our writings on:<br><br> <a href="https://baptistnews.com/projects/faith-justice/">Faith and Justice</a><br> <a href="https://baptistnews.com/projects/welcoming-the-stranger/#.XbMIyOdKjOQ">Welcoming The Stranger</a><br><a href="https://baptistnews.com/projects/signature-ministries/#.XbMI4-dKjOQ">Signature Ministries</a><br><a href="https://baptistnews.com/projects/singing-our-faith/#.XbMI9-dKjOQ">Singing Our Faith</a><br><a href="https://baptistnews.com/projects/resilient-rural-america/#.XbMJKudKjOQ">Resilient Rural America</a><br><br><a href="https://baptistnews.com/projects/#.XbMIiOdKjOQ"><img class="wp-image-109065 jetpack-lazy-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2017/12/BNG_STP.jpg" alt width="300" height="200" data-lazy-src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2017/12/BNG_STP.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="wp-image-109065" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2017/12/BNG_STP.jpg" alt="" width="300" height="200"/></noscript></a></div></li>		
		<div class="sidebar-featured">
						<h4 class="upper">Featured</h3>
			<ul class="sidebar-featured-ul">
							    <li class="sidebar-featured-item">
						<a href="https://baptistnews.com/article/daring-to-enter-the-black-holes-of-racism-to-do-the-cosmic-work-of-racial-justice/">
				    								<div class="left-third">
								<img src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/09/ericawhitaker-300x200.jpg" />
							</div><!--/.left-third-->
				    	<div class="right-twothirds">
					    	<h5>Daring to enter the black holes of racism to do the cosmic work of racial justice</h5>
					    	<p class="entry-meta"><span class="category opinion">Opinion</span></p>				    	</div><!--/.right-twothirds-->
			    	</a>
			    </li><!--/.sidebar-featured-item-->
							    <li class="sidebar-featured-item">
						<a href="https://baptistnews.com/article/faith-leaders-see-nones-coming-to-church-for-community-spiritual-direction/">
				    								<div class="left-third">
								<img src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Labrynth-Michael-Pittman-300x200.jpg" />
							</div><!--/.left-third-->
				    	<div class="right-twothirds">
					    	<h5>Faith leaders see &#8216;nones&#8217; coming to church for community, spiritual direction</h5>
					    	<p class="entry-meta"><span class="category news">News</span></p>				    	</div><!--/.right-twothirds-->
			    	</a>
			    </li><!--/.sidebar-featured-item-->
							    <li class="sidebar-featured-item">
						<a href="https://baptistnews.com/article/from-spreading-ashes-to-administering-them-ash-wednesday-for-a-broken-and-grieving-minister/">
				    								<div class="left-third">
								<img src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/rebekah-gordon-300x200.png" />
							</div><!--/.left-third-->
				    	<div class="right-twothirds">
					    	<h5>From spreading ashes to administering them: Ash Wednesday for a broken and grieving minister</h5>
					    	<p class="entry-meta"><span class="category opinion">Opinion</span></p>				    	</div><!--/.right-twothirds-->
			    	</a>
			    </li><!--/.sidebar-featured-item-->
							    <li class="sidebar-featured-item">
						<a href="https://baptistnews.com/article/biden-buttigieg-begin-busy-week-leading-up-to-south-carolina-primary-in-church/">
				    								<div class="left-third">
								<img src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/faith-in-the-race-300x200.jpg" />
							</div><!--/.left-third-->
				    	<div class="right-twothirds">
					    	<h5>Biden, Buttigieg begin busy week leading up to South Carolina primary in church</h5>
					    	<p class="entry-meta"><span class="category news">News</span></p>				    	</div><!--/.right-twothirds-->
			    	</a>
			    </li><!--/.sidebar-featured-item-->
							</ul><!--/.sidebar-featured-ul-->
					</div><!--/.sidebar-featured-->
		<!--	<div class="email-signup">
		<h4>Get <strong><img src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/bng/images/icon-bng.svg" />BNG</strong> headlines in your inbox</h4>
		
		<form class="email-signup-form" action="//baptistnews.us4.list-manage.com/subscribe/post?u=fe721f40103f50684ed42c88b&amp;id=dd0edff639" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" target="_blank" novalidate>
			<input type="hidden" name="id" value="4efde2bece">
			<input class="input50" type="text" name="FNAME" id="mce-FNAME" size="25" placeholder="First Name">
			<input class="input50 input50last" type="text" name="LNAME" id="mce-LNAME" size="25" placeholder="Last Name">
			<input type="email" autocapitalize="off" autocorrect="off" name="EMAIL" id="mce-EMAIL" size="25" placeholder="name@example.com">
			
			<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_fe721f40103f50684ed42c88b_dd0edff639" tabindex="-1" value=""></div>
	    <div class="clear">

			<div id="mce-responses" class="clear">
				<div class="response" id="mce-error-response" style="display:none"></div>
				<div class="response" id="mce-success-response" style="display:none"></div>
			</div><!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
						
<!--			<input type="submit" value="Sign up" name="subscribe" id="mc-embedded-subscribe" class="button"></div>

		</form><!--/.email-signup-form-->
		
		<!--<script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js'></script><script type='text/javascript'>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[2]='LNAME';ftypes[2]='text';fnames[14]='MMERGE14';ftypes[14]='text';fnames[15]='MMERGE15';ftypes[15]='text';}(jQuery));var $mcj = jQuery.noConflict(true);</script>-->
		
<!--	</div><!--/.email-signup-->
		</aside><!--/.sidebar-->
	</div></div>	<div class="post-bottom">
		<article class="read-next">
			<div><a href="https://baptistnews.com/article/lets-bury-the-patriarchal-narrative-in-american-culture-politics-and-churches-are-good-places-to-start/"><span class="wrap"><h6>Read Next:</h6><span class="alignleft"><img class="" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/06/molly-marshall_small-299x150.jpg" /></span><h2>Let’s bury the patriarchal narrative in American culture. Politics and churches are good places to start</h2><p class="entry-meta"><span class="category opinion">Opinion</span>Molly T. Marshall</p></span></a></div>		</article><!--/.read-next-->
		
		<div class="related-posts">
			<div class="wrap">
				<h4>More <strong>Articles</strong></h4>
				<ul class="show-only upper xsmall">
					<li class="active" data-tab="all"><a href="#all">All</a></li>
					<li data-tab="news"><a href="#news">News</a></li>
					<li data-tab="opinion"><a href="#opinion">Opinion</a></li>
					<li data-tab="curated"><a href="#curated">Curated</a></li>					
				</ul><!--/.show-only-->
				
				<ul class="related-posts-list posts-all active">
													<li class="clearfix">
						<a href="https://baptistnews.com/article/lent-2020-improvising-grace-and-embracing-repentance-civility-and-dissent-in-a-time-of-national-urgency/" title="Lent 2020: Improvising grace and embracing repentance, civility and dissent in ‘a time of national urgency’">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/02/Leonard_Bill-300x200-1.jpg" />
							<h3>Lent 2020: Improvising grace and embracing repentance, civility and dissent in ‘a time of national urgency’</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Bill Leonard</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/what-an-open-door-to-asylum-seekers-looks-like/" title="What an open door to asylum seekers looks like">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Christian-Century-300x200.png" />
							<h3>What an open door to asylum seekers looks like</h3>
							<p class="entry-meta"><span class="category curated">Curated</span>The Christian Century</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/how-churches-are-addressing-voter-suppression/" title="How churches are addressing voter suppression">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/sojo-300x200.png" />
							<h3>How churches are addressing voter suppression</h3>
							<p class="entry-meta"><span class="category curated">Curated</span>Sojourners</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/missouri-baptist-trustee-tussle-returns-spotlight-to-old-allegations-of-mishandled-abuse/" title="Missouri Baptist trustee tussle returns spotlight to old allegations of mishandled abuse">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/cheryl_summers-300x200.jpg" />
							<h3>Missouri Baptist trustee tussle returns spotlight to old allegations of mishandled abuse</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/daring-to-enter-the-black-holes-of-racism-to-do-the-cosmic-work-of-racial-justice/" title="Daring to enter the black holes of racism to do the cosmic work of racial justice">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/09/ericawhitaker-300x200.jpg" />
							<h3>Daring to enter the black holes of racism to do the cosmic work of racial justice</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Erica Whitaker</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/faith-leaders-see-nones-coming-to-church-for-community-spiritual-direction/" title="Faith leaders see &#8216;nones&#8217; coming to church for community, spiritual direction">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Labrynth-Michael-Pittman-300x200.jpg" />
							<h3>Faith leaders see &#8216;nones&#8217; coming to church for community, spiritual direction</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/biden-buttigieg-begin-busy-week-leading-up-to-south-carolina-primary-in-church/" title="Biden, Buttigieg begin busy week leading up to South Carolina primary in church">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/faith-in-the-race-300x200.jpg" />
							<h3>Biden, Buttigieg begin busy week leading up to South Carolina primary in church</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/from-spreading-ashes-to-administering-them-ash-wednesday-for-a-broken-and-grieving-minister/" title="From spreading ashes to administering them: Ash Wednesday for a broken and grieving minister">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/rebekah-gordon-300x200.png" />
							<h3>From spreading ashes to administering them: Ash Wednesday for a broken and grieving minister</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Rebekah Gordon</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/ministry-jobs-and-more-112/" title="Ministry jobs and more">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/02/ministry-cover-1-300x200.jpg" />
							<h3>Ministry jobs and more</h3>
							<p class="entry-meta"><span class="category news">News</span>Barbara Francis</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/are-lgbtq-people-deserving-of-death-christian-writers-must-watch-their-rhetoric/" title="Are LGBTQ people deserving of death? Christian writers must watch their rhetoric">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/09/Trammell2019-300x200.jpg" />
							<h3>Are LGBTQ people deserving of death? Christian writers must watch their rhetoric</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Jim Y. Trammell</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/dont-panic-mom-and-dad-your-kids-tattoo-may-reinforce-religious-identity/" title="Don&#8217;t panic, mom and dad: your kid&#8217;s tattoo may reinforce religious identity">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/TATTOO-LearningLark-300x200.jpg" />
							<h3>Don&#8217;t panic, mom and dad: your kid&#8217;s tattoo may reinforce religious identity</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/pressler-accuser-still-wants-day-in-court/" title="Pressler accuser still wants day in court">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/11/pressler_sbc-300x200.jpg" />
							<h3>Pressler accuser still wants day in court</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/lets-bury-the-patriarchal-narrative-in-american-culture-politics-and-churches-are-good-places-to-start/" title="Let’s bury the patriarchal narrative in American culture. Politics and churches are good places to start">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/06/molly-marshall_small-299x200.jpg" />
							<h3>Let’s bury the patriarchal narrative in American culture. Politics and churches are good places to start</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Molly T. Marshall</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/social-media-pick-up-historic-little-rock-nine-photos-every-february-but-racial-injustice-is-a-present-reality/" title="White America has been lying to itself about who we really are">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/LMayo2019-300x200.jpg" />
							<h3>White America has been lying to itself about who we really are</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Laura Mayo</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/hundreds-of-supporters-seek-answers-about-closing-of-logsdon-seminary-in-open-letter/" title="Hundreds of supporters seek answers about closing of Logsdon Seminary in open letter">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/eric_bruntmyer-300x200.png" />
							<h3>Hundreds of supporters seek answers about closing of Logsdon Seminary in open letter</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/suckers-for-trump-some-ideas-for-groups-that-can-build-on-the-white-evangelical-base/" title="Suckers for Trump: some ideas for groups that can build on the white evangelical base">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/01/EBridges2020-300x200.png" />
							<h3>Suckers for Trump: some ideas for groups that can build on the white evangelical base</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Erich Bridges</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/transitions-for-the-week-of-2-21-20/" title="Transitions for the week of 2-21-20">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/02/shutterstock_550842946-e1517579132680-300x200.jpg" />
							<h3>Transitions for the week of 2-21-20</h3>
							<p class="entry-meta"><span class="category news">News</span>Barbara Francis</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/trumps-middle-east-peace-plan-makes-sense-until-you-read-it-christian-peace-activist-says/" title="Trump&#8217;s Middle East peace plan makes sense until you read it, Christian peace activist says">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Palestine-Wall-1600-Paolo-Cuttitta-300x200.jpg" />
							<h3>Trump&#8217;s Middle East peace plan makes sense until you read it, Christian peace activist says</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/re-setting-broken-bones-why-the-oft-lamented-division-in-our-culture-is-necessary-and-helpful/" title="Re-setting broken bones: Why the oft-lamented division in our culture is necessary and helpful">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/greg-jarrell-300x200.jpg" />
							<h3>Re-setting broken bones: Why the oft-lamented division in our culture is necessary and helpful</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Greg Jarrell</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/letter-to-the-editor-explaining-the-silence-from-hardin-simmons-faculty-and-staff/" title="Letter to the Editor &#8211; Explaining the silence from Hardin-Simmons faculty and staff">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/04/Letters_to_editor_artwork-300x200.jpg" />
							<h3>Letter to the Editor &#8211; Explaining the silence from Hardin-Simmons faculty and staff</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/cbf-foundation-fellowship-select-former-moderator-shauw-chin-capps-for-joint-leadership-post/" title="CBF Foundation, Fellowship select former moderator Shauw Chin Capps for joint leadership post">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/06/shauw_chin_bcbf-300x200.jpg" />
							<h3>CBF Foundation, Fellowship select former moderator Shauw Chin Capps for joint leadership post</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/cbf-of-texas-leaders-criticize-closure-of-partner-seminary/" title="CBF of Texas leaders criticize closure of partner seminary">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/stephanie_nash-300x200.png" />
							<h3>CBF of Texas leaders criticize closure of partner seminary</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/the-looming-prophetic-crisis-and-the-urgency-for-truth-telling/" title="The looming prophetic crisis and the urgency for truth-telling">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2017/10/AuthorWENDELLGR_00000119798-e1509386837993-299x200.jpg" />
							<h3>The looming prophetic crisis and the urgency for truth-telling</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Wendell Griffen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/ministry-jobs-and-more-111/" title="Ministry jobs and more">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/02/ministry-cover-1-300x200.jpg" />
							<h3>Ministry jobs and more</h3>
							<p class="entry-meta"><span class="category news">News</span>Barbara Francis</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/spokesman-says-conservative-baptist-network-already-a-success/" title="Spokesman says Conservative Baptist Network already a success">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Capture_conservative_baptist_network-300x200.png" />
							<h3>Spokesman says Conservative Baptist Network already a success</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
									</ul><!--/.posts-all-->
				
				<ul class="related-posts-list posts-news">
													<li class="clearfix">
						<a href="https://baptistnews.com/article/missouri-baptist-trustee-tussle-returns-spotlight-to-old-allegations-of-mishandled-abuse/" title="Missouri Baptist trustee tussle returns spotlight to old allegations of mishandled abuse">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/cheryl_summers-300x200.jpg" />
							<h3>Missouri Baptist trustee tussle returns spotlight to old allegations of mishandled abuse</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/faith-leaders-see-nones-coming-to-church-for-community-spiritual-direction/" title="Faith leaders see &#8216;nones&#8217; coming to church for community, spiritual direction">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Labrynth-Michael-Pittman-300x200.jpg" />
							<h3>Faith leaders see &#8216;nones&#8217; coming to church for community, spiritual direction</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/biden-buttigieg-begin-busy-week-leading-up-to-south-carolina-primary-in-church/" title="Biden, Buttigieg begin busy week leading up to South Carolina primary in church">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/faith-in-the-race-300x200.jpg" />
							<h3>Biden, Buttigieg begin busy week leading up to South Carolina primary in church</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/ministry-jobs-and-more-112/" title="Ministry jobs and more">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/02/ministry-cover-1-300x200.jpg" />
							<h3>Ministry jobs and more</h3>
							<p class="entry-meta"><span class="category news">News</span>Barbara Francis</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/dont-panic-mom-and-dad-your-kids-tattoo-may-reinforce-religious-identity/" title="Don&#8217;t panic, mom and dad: your kid&#8217;s tattoo may reinforce religious identity">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/TATTOO-LearningLark-300x200.jpg" />
							<h3>Don&#8217;t panic, mom and dad: your kid&#8217;s tattoo may reinforce religious identity</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/pressler-accuser-still-wants-day-in-court/" title="Pressler accuser still wants day in court">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/11/pressler_sbc-300x200.jpg" />
							<h3>Pressler accuser still wants day in court</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/hundreds-of-supporters-seek-answers-about-closing-of-logsdon-seminary-in-open-letter/" title="Hundreds of supporters seek answers about closing of Logsdon Seminary in open letter">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/eric_bruntmyer-300x200.png" />
							<h3>Hundreds of supporters seek answers about closing of Logsdon Seminary in open letter</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/transitions-for-the-week-of-2-21-20/" title="Transitions for the week of 2-21-20">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/02/shutterstock_550842946-e1517579132680-300x200.jpg" />
							<h3>Transitions for the week of 2-21-20</h3>
							<p class="entry-meta"><span class="category news">News</span>Barbara Francis</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/trumps-middle-east-peace-plan-makes-sense-until-you-read-it-christian-peace-activist-says/" title="Trump&#8217;s Middle East peace plan makes sense until you read it, Christian peace activist says">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Palestine-Wall-1600-Paolo-Cuttitta-300x200.jpg" />
							<h3>Trump&#8217;s Middle East peace plan makes sense until you read it, Christian peace activist says</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/cbf-foundation-fellowship-select-former-moderator-shauw-chin-capps-for-joint-leadership-post/" title="CBF Foundation, Fellowship select former moderator Shauw Chin Capps for joint leadership post">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/06/shauw_chin_bcbf-300x200.jpg" />
							<h3>CBF Foundation, Fellowship select former moderator Shauw Chin Capps for joint leadership post</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/cbf-of-texas-leaders-criticize-closure-of-partner-seminary/" title="CBF of Texas leaders criticize closure of partner seminary">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/stephanie_nash-300x200.png" />
							<h3>CBF of Texas leaders criticize closure of partner seminary</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/ministry-jobs-and-more-111/" title="Ministry jobs and more">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/02/ministry-cover-1-300x200.jpg" />
							<h3>Ministry jobs and more</h3>
							<p class="entry-meta"><span class="category news">News</span>Barbara Francis</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/spokesman-says-conservative-baptist-network-already-a-success/" title="Spokesman says Conservative Baptist Network already a success">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Capture_conservative_baptist_network-300x200.png" />
							<h3>Spokesman says Conservative Baptist Network already a success</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/grieving-logsdon-supporters-fear-female-prof-a-victim-of-conservatives-behind-seminarys-closure/" title="Grieving Logsdon supporters fear female prof a victim of conservatives behind seminary&#8217;s closure">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Capture_logsdonwindow-1-300x200.png" />
							<h3>Grieving Logsdon supporters fear female prof a victim of conservatives behind seminary&#8217;s closure</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/james-leo-garrett-theologian-who-influenced-two-generations-of-baptist-scholars-dead-at-94/" title="James Leo Garrett, theologian who influenced two generations of Baptist scholars, dead at 94">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/james_leo_garrett_banner-300x200.jpg" />
							<h3>James Leo Garrett, theologian who influenced two generations of Baptist scholars, dead at 94</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/religion-notes-ministries-unite-to-open-new-shelters-on-u-s-mexico-border/" title="Religion Notes: Ministries unite to open new shelters on U.S.-Mexico border">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/11/CaravanJonathan-McIntosh-300x200.jpg" />
							<h3>Religion Notes: Ministries unite to open new shelters on U.S.-Mexico border</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/ministry-jobs-and-more-110/" title="Ministry jobs and more">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/02/ministry-cover-1-300x200.jpg" />
							<h3>Ministry jobs and more</h3>
							<p class="entry-meta"><span class="category news">News</span>Barbara Francis</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/cbf-church-booted-from-southern-baptist-association-for-embracing-lgbtq-members/" title="CBF church booted from Southern Baptist association for embracing LGBTQ members">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/First-Baptist-Church-Of-Decatur-Wedding-Atlanta-GA-3_main.1498592419-300x200.jpg" />
							<h3>CBF church booted from Southern Baptist association for embracing LGBTQ members</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/logsdon-seminary-closure-prompts-mourning-and-protests/" title="Logsdon Seminary closure prompts mourning and protests (updated)">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Capture_logsdonwindow-1-300x200.png" />
							<h3>Logsdon Seminary closure prompts mourning and protests (updated)</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/why-infant-baptism-wont-impede-baptist-methodist-cooperation-in-texas/" title="Why infant baptism won&#8217;t impede Baptist-Methodist cooperation in Texas">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/handshakejeanbaptiseparis-300x200.jpg" />
							<h3>Why infant baptism won&#8217;t impede Baptist-Methodist cooperation in Texas</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/namb-lawsuit-tests-when-courts-can-and-cannot-resolve-disputes-in-religious-bodies/" title="NAMB lawsuit tests when courts can – and cannot – resolve disputes in religious bodies">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/Capture_mcraneys-1-300x200.png" />
							<h3>NAMB lawsuit tests when courts can – and cannot – resolve disputes in religious bodies</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/politics-is-becoming-a-four-letter-word-in-american-society/" title="&#8216;Politics&#8217; is becoming a four-letter word in American society">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/ARGUMENT-300x200.jpg" />
							<h3>&#8216;Politics&#8217; is becoming a four-letter word in American society</h3>
							<p class="entry-meta"><span class="category news">News</span>Jeff Brumley</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/william-barber-says-trumps-acquittal-a-form-of-southern-justice/" title="William Barber says Trump’s acquittal a form of ‘Southern Justice’">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/william_barber-300x200.jpg" />
							<h3>William Barber says Trump’s acquittal a form of ‘Southern Justice’</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/southern-baptist-senator-says-his-conscience-is-clear-after-trump-acquittal/" title="Southern Baptist senator says his conscience is clear after Trump acquittal">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Stefan_Lochner_-_Last_Judgement_-_circa_1435-300x200.jpg" />
							<h3>Southern Baptist senator says his conscience is clear after Trump acquittal</h3>
							<p class="entry-meta"><span class="category news">News</span>Bob Allen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/transitions-for-the-week-of-2-7-20/" title="Transitions for the week of 2-7-20">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/02/shutterstock_550842946-e1517579132680-300x200.jpg" />
							<h3>Transitions for the week of 2-7-20</h3>
							<p class="entry-meta"><span class="category news">News</span>Barbara Francis</p>						</a>
					</li>
									</ul><!--/.posts-news-->

				<ul class="related-posts-list posts-opinion">
													<li class="clearfix">
						<a href="https://baptistnews.com/article/lent-2020-improvising-grace-and-embracing-repentance-civility-and-dissent-in-a-time-of-national-urgency/" title="Lent 2020: Improvising grace and embracing repentance, civility and dissent in ‘a time of national urgency’">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/02/Leonard_Bill-300x200-1.jpg" />
							<h3>Lent 2020: Improvising grace and embracing repentance, civility and dissent in ‘a time of national urgency’</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Bill Leonard</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/daring-to-enter-the-black-holes-of-racism-to-do-the-cosmic-work-of-racial-justice/" title="Daring to enter the black holes of racism to do the cosmic work of racial justice">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/09/ericawhitaker-300x200.jpg" />
							<h3>Daring to enter the black holes of racism to do the cosmic work of racial justice</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Erica Whitaker</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/from-spreading-ashes-to-administering-them-ash-wednesday-for-a-broken-and-grieving-minister/" title="From spreading ashes to administering them: Ash Wednesday for a broken and grieving minister">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/rebekah-gordon-300x200.png" />
							<h3>From spreading ashes to administering them: Ash Wednesday for a broken and grieving minister</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Rebekah Gordon</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/are-lgbtq-people-deserving-of-death-christian-writers-must-watch-their-rhetoric/" title="Are LGBTQ people deserving of death? Christian writers must watch their rhetoric">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/09/Trammell2019-300x200.jpg" />
							<h3>Are LGBTQ people deserving of death? Christian writers must watch their rhetoric</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Jim Y. Trammell</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/lets-bury-the-patriarchal-narrative-in-american-culture-politics-and-churches-are-good-places-to-start/" title="Let’s bury the patriarchal narrative in American culture. Politics and churches are good places to start">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/06/molly-marshall_small-299x200.jpg" />
							<h3>Let’s bury the patriarchal narrative in American culture. Politics and churches are good places to start</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Molly T. Marshall</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/social-media-pick-up-historic-little-rock-nine-photos-every-february-but-racial-injustice-is-a-present-reality/" title="White America has been lying to itself about who we really are">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/LMayo2019-300x200.jpg" />
							<h3>White America has been lying to itself about who we really are</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Laura Mayo</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/suckers-for-trump-some-ideas-for-groups-that-can-build-on-the-white-evangelical-base/" title="Suckers for Trump: some ideas for groups that can build on the white evangelical base">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/01/EBridges2020-300x200.png" />
							<h3>Suckers for Trump: some ideas for groups that can build on the white evangelical base</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Erich Bridges</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/re-setting-broken-bones-why-the-oft-lamented-division-in-our-culture-is-necessary-and-helpful/" title="Re-setting broken bones: Why the oft-lamented division in our culture is necessary and helpful">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/greg-jarrell-300x200.jpg" />
							<h3>Re-setting broken bones: Why the oft-lamented division in our culture is necessary and helpful</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Greg Jarrell</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/letter-to-the-editor-explaining-the-silence-from-hardin-simmons-faculty-and-staff/" title="Letter to the Editor &#8211; Explaining the silence from Hardin-Simmons faculty and staff">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/04/Letters_to_editor_artwork-300x200.jpg" />
							<h3>Letter to the Editor &#8211; Explaining the silence from Hardin-Simmons faculty and staff</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/the-looming-prophetic-crisis-and-the-urgency-for-truth-telling/" title="The looming prophetic crisis and the urgency for truth-telling">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2017/10/AuthorWENDELLGR_00000119798-e1509386837993-299x200.jpg" />
							<h3>The looming prophetic crisis and the urgency for truth-telling</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Wendell Griffen</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/letter-to-the-editor-hsus-move-against-pigott-devastating/" title="Letter to the Editor &#8211; HSU&#8217;s move against Pigott &#8216;devastating&#8217;">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/04/Letters_to_editor_artwork-300x200.jpg" />
							<h3>Letter to the Editor &#8211; HSU&#8217;s move against Pigott &#8216;devastating&#8217;</h3>
							<p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span><p class="entry-meta"><span class="category opinion">Opinion</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/letter-to-the-editor-for-2-17-20/" title="Letter to the Editor for 2.17.20">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/04/Letters_to_editor_artwork-300x200.jpg" />
							<h3>Letter to the Editor for 2.17.20</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/has-conservative-evangelicalism-reached-a-dangerous-moment-of-its-own-making/" title="Has conservative evangelicalism reached a dangerous moment of its own making?">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/09/susanmshaw-300x200.jpg" />
							<h3>Has conservative evangelicalism reached a dangerous moment of its own making?</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Susan M. Shaw</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/losing-logsdon-seminary-broken-commitments-and-wounded-spirits/" title="Losing Logsdon Seminary: broken commitments and wounded spirits">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/08/Sellers-300x200.jpg" />
							<h3>Losing Logsdon Seminary: broken commitments and wounded spirits</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Robert P. Sellers</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/letter-to-the-editor-response-to-logsdon-closing/" title="Letter to the Editor &#8211; Response to Logsdon closing">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/04/Letters_to_editor_artwork-300x200.jpg" />
							<h3>Letter to the Editor &#8211; Response to Logsdon closing</h3>
							<p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span><p class="entry-meta"><span class="category opinion">Opinion</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/letter-to-the-editor-for-2-13-20/" title="Letter to the Editor for 2.13.20">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/04/Letters_to_editor_artwork-300x200.jpg" />
							<h3>Letter to the Editor for 2.13.20</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/aaron-sorkin-presents-the-prodigal-son/" title="Aaron Sorkin Presents ‘The Prodigal Son’">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/03/Younger_Brett_enews-300x200.jpg" />
							<h3>Aaron Sorkin Presents ‘The Prodigal Son’</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Brett Younger</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/logsdon-seminary-will-be-shuttered-7-questions-for-hardin-simmons-universitys-president-and-trustees/" title="Logsdon Seminary will be shuttered: 7 Questions for Hardin-Simmons University’s president and trustees">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/03/Davis_Jonathan_Cropped-300x300-300x200.jpg" />
							<h3>Logsdon Seminary will be shuttered: 7 Questions for Hardin-Simmons University’s president and trustees</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Jonathan Davis</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/character-matters-but-policy-matters-more-christians-should-know-that/" title="Character matters, but policy matters more. Christians should know that">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/coreyfields-300x200.png" />
							<h3>Character matters, but policy matters more. Christians should know that</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Corey Fields</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/conscience-more-or-less-roger-williams-mitt-romney-and-the-rest-of-us/" title="‘Conscience … more or less’: Roger Williams, Mitt Romney and the rest of us">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/02/Leonard_Bill-300x200.jpg" />
							<h3>‘Conscience … more or less’: Roger Williams, Mitt Romney and the rest of us</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Bill Leonard</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/black-history-month-and-telling-the-whole-story/" title="Black History Month: I’m all in, but let’s tell the WHOLE story">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2019/07/P-Ford-2019-300x200.jpg" />
							<h3>Black History Month: I’m all in, but let’s tell the WHOLE story</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Paul Robeson Ford</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/letter-to-the-editor-amen-to-eric-mintons-commentary/" title="Letter to the Editor &#8211; Amen to Eric Minton’s commentary">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/04/Letters_to_editor_artwork-300x200.jpg" />
							<h3>Letter to the Editor &#8211; Amen to Eric Minton’s commentary</h3>
							<p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span><p class="entry-meta"><span class="category opinion">Opinion</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/trans-101-for-churches-ways-to-make-a-difference-for-transgender-persons/" title="Trans 101 for churches: ways to make a difference for transgender persons">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/ShawMcComb-300x200.png" />
							<h3>Trans 101 for churches: ways to make a difference for transgender persons</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Susan M. Shaw Brenda McComb</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/letter-to-the-editor-for-2-06-20/" title="Letter to the Editor for 2.6.20">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2016/04/Letters_to_editor_artwork-300x200.jpg" />
							<h3>Letter to the Editor for 2.6.20</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>BNG staff</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/in-a-messy-election-year-lets-remember-that-the-golden-rule-applies-to-politics-too/" title="In a messy election year, let’s remember that the ‘Golden Rule’ applies to politics too">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/03/Sager_Doyle_2018-300x200.jpg" />
							<h3>In a messy election year, let’s remember that the ‘Golden Rule’ applies to politics too</h3>
							<p class="entry-meta"><span class="category opinion">Opinion</span>Doyle Sager</p>						</a>
					</li>
									</ul><!--/.posts-opinion-->
				
				<ul class="related-posts-list posts-curated">
													<li class="clearfix">
						<a href="https://baptistnews.com/article/what-an-open-door-to-asylum-seekers-looks-like/" title="What an open door to asylum seekers looks like">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Christian-Century-300x200.png" />
							<h3>What an open door to asylum seekers looks like</h3>
							<p class="entry-meta"><span class="category curated">Curated</span>The Christian Century</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/how-churches-are-addressing-voter-suppression/" title="How churches are addressing voter suppression">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/sojo-300x200.png" />
							<h3>How churches are addressing voter suppression</h3>
							<p class="entry-meta"><span class="category curated">Curated</span>Sojourners</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/chinese-american-churches-on-the-frontlines-of-coronavirus-vigilance/" title="Chinese American churches on the frontlines of coronavirus vigilance">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/CTLogo-300x200.png" />
							<h3>Chinese American churches on the frontlines of coronavirus vigilance</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/the-religious-mourning-of-saint-kobe-bryant-continues/" title="The religious mourning of ‘Saint’ Kobe Bryant continues">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Religion-Dispatches-300x200.png" />
							<h3>The religious mourning of ‘Saint’ Kobe Bryant continues</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/i-thought-i-would-find-a-husband-not-a-stalker-do-religious-dating-apps-put-women-in-danger/" title="‘I thought I would find a husband, not a stalker’: Do religious dating apps put women in danger?">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Deseret-News-300x200.png" />
							<h3>‘I thought I would find a husband, not a stalker’: Do religious dating apps put women in danger?</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/solidarity-over-segregation-faith-based-coalitions-organize-across-races-religions/" title="Solidarity over segregation: Faith-based coalitions organize across races, religions">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/RNS-sticker-300x200.png" />
							<h3>Solidarity over segregation: Faith-based coalitions organize across races, religions</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/first-baptist-church-hosts-christianity-and-transgender-inclusion-seminar/" title="First Baptist Church hosts Christianity and transgender inclusion seminar">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Missourian-300x200.png" />
							<h3>First Baptist Church hosts Christianity and transgender inclusion seminar</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/tiffany-church-window-unnoticed-in-providence-will-be-a-star-attraction-in-chicago-art-museum/" title="Tiffany church window, unnoticed in Providence, will be a star attraction in Chicago art museum">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Untitled_providence-journal-300x200.png" />
							<h3>Tiffany church window, unnoticed in Providence, will be a star attraction in Chicago art museum</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/wake-forest-university-apologizes-for-its-past-role-in-slavery/" title="Wake Forest University apologizes for its past role in slavery">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/winston_salem_journal-300x200.png" />
							<h3>Wake Forest University apologizes for its past role in slavery</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/dispute-over-russell-moore-politics-trump-and-money-for-missions-behind-erlc-review/" title="Dispute over Russell Moore, politics, Trump and money for missions behind ERLC review">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/RNS-sticker-300x200.png" />
							<h3>Dispute over Russell Moore, politics, Trump and money for missions behind ERLC review</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/stresses-multiply-for-many-us-clergy-we-need-help-too/" title="Stresses multiply for many US clergy: ‘We need help too’">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/AP-300x200.png" />
							<h3>Stresses multiply for many US clergy: ‘We need help too’</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/it-matters-that-michael-bloomberg-is-a-proud-jew/" title="It matters that Michael Bloomberg is a proud Jew">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Jewish_journal-300x200.png" />
							<h3>It matters that Michael Bloomberg is a proud Jew</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/texas-church-expelled-from-southern-baptist-convention-for-hiring-sex-offender-as-pastor/" title="Texas church expelled from Southern Baptist Convention for hiring sex offender as pastor">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/USAToday-300x144.png" />
							<h3>Texas church expelled from Southern Baptist Convention for hiring sex offender as pastor</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/a-guatemalan-family-was-separated-in-2017-theyre-still-apart/" title="A Guatemalan family was separated in 2017. They&#8217;re still apart">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/washington-post-300x200.jpg" />
							<h3>A Guatemalan family was separated in 2017. They&#8217;re still apart</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/evangelical-pastor-has-a-simple-mission-get-trump-out/" title="Evangelical pastor has a simple mission: Get Trump out">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/RNS-sticker-300x200.png" />
							<h3>Evangelical pastor has a simple mission: Get Trump out</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/christian-lawmakers-group-blames-satan-after-twitter-poll-goes-badly-awry/" title="Christian lawmakers group blames Satan after Twitter poll goes badly awry">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/08/TST-baph-statue-740x525-300x200.jpg" />
							<h3>Christian lawmakers group blames Satan after Twitter poll goes badly awry</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/even-for-christians-trump-has-become-a-dating-deal-breaker/" title="Even for Christians, Trump has become a dating deal-breaker">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/CTLogo-300x200.png" />
							<h3>Even for Christians, Trump has become a dating deal-breaker</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/gospel-of-matthews-message-rings-loudly-for-some-2020-dems/" title="Gospel of Matthew’s message rings loudly for some 2020 Dems">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Pete_matt_25-300x200.jpg" />
							<h3>Gospel of Matthew’s message rings loudly for some 2020 Dems</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/why-do-we-celebrate-valentines-day-in-the-early-years-it-was-more-goat-blood-than-roses/" title="Why do we celebrate Valentine&#8217;s Day? In the early years, it was more goat blood than roses">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/Valentines_Day_Credit_MarjanCermelj__Shutterstock-300x200.jpg" />
							<h3>Why do we celebrate Valentine&#8217;s Day? In the early years, it was more goat blood than roses</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/top-southern-baptist-leader-resigns-over-inappropriate-relationship-now-leads-s-c-church/" title="Top Southern Baptist leader resigns over inappropriate relationship, now leads S.C. church">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2018/03/Frank-Page-300x200.jpg" />
							<h3>Top Southern Baptist leader resigns over inappropriate relationship, now leads S.C. church</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/justice-department-anti-human-trafficking-grants-prompt-whistleblower-complaint/" title="Justice Department anti-human trafficking grants prompt whistleblower complaint">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/hookers_for_jesus-300x200.jpg" />
							<h3>Justice Department anti-human trafficking grants prompt whistleblower complaint</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/the-tongue-is-a-fire-southern-baptist-church-fractures-over-secrets-and-spiritual-abuse/" title="‘The tongue is a fire’: Southern Baptist church fractures over secrets and spiritual abuse">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/oakwood-300x200.jpg" />
							<h3>‘The tongue is a fire’: Southern Baptist church fractures over secrets and spiritual abuse</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/more-us-firms-are-boosting-faith-based-support-for-employees/" title="More US firms are boosting faith-based support for employees">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/tyson_foods-300x200.jpg" />
							<h3>More US firms are boosting faith-based support for employees</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/is-the-rise-of-the-nones-slowing-scholars-say-maybe/" title="Is the rise of the Nones slowing? Scholars say maybe">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/RNS-sticker-300x200.png" />
							<h3>Is the rise of the Nones slowing? Scholars say maybe</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
										<li class="clearfix">
						<a href="https://baptistnews.com/article/louisiana-church-fires-holden-matthews-pleads-guilty-to-state-federal-crimes/" title="Louisiana church fires: Holden Matthews pleads guilty to state, federal crimes">
														<img class="alignleft post-image" src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/uploads/2020/02/holden_matthews_fire-300x200.jpg" />
							<h3>Louisiana church fires: Holden Matthews pleads guilty to state, federal crimes</h3>
							<p class="entry-meta"><span class="category curated">Curated</span><p class="entry-meta"><span class="category exclude-from-home-page">Exclude from home page</span>Curated Content</p>						</a>
					</li>
									</ul><!--/.posts-curated-->
				
			</div><!--/.wrap-->
		</div><!--/.related-posts-->
	</div><!--/.post-bottom-->
	<footer class="site-footer"><div class="wrap">	<p><img src="https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/bng/images/icon-bng.svg" /></p>
	<h5 class="upper">Conversations that Matter.</h5>
	<p class="upper small">&copy; 2020 Baptist News Global. All rights reserved.</p>
	<p class="small">Want to share a story? We hope you will! Read our republishing, terms of use and privacy policies <a href="/bng-terms-of-use">here</a>.</p>
	
	<ul class="social-links">
		<li class="social-facebook"><a target="_blank" href="https://www.facebook.com/BaptistNewsGlobal/"><svg id="Icon" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 36 35.99"><defs><style>.cls-1{fill:#c2cad1;}</style></defs><title>Facebook</title><path class="cls-1" d="M29,3.7H7A3.66,3.66,0,0,0,3.33,7.36V29.31A3.66,3.66,0,0,0,7,33H19.17V21.13H16.51V17h2.59c0-1.22,0-2.3,0-3.42,0-3.24,2.49-4.18,4.72-4.18h3.77v4.06H25.4A1.24,1.24,0,0,0,24,14.69C24,15.21,24,17,24,17H27.6l-0.29,4H24.08V33H29a3.66,3.66,0,0,0,3.67-3.66V7.36A3.66,3.66,0,0,0,29,3.7Z"/></svg></a></li>
		
		<li class="social-twitter"><a target="_blank" href="https://twitter.com/baptist_news"><svg id="Icon" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 36 35.99"><defs><style>.cls-1{fill:#c2cad1;}</style></defs><title>Twitter</title><path class="cls-1" d="M34.17,8.55a12.47,12.47,0,0,1-3.59,1,6.27,6.27,0,0,0,2.75-3.46,12.48,12.48,0,0,1-4,1.52,6.25,6.25,0,0,0-10.81,4.28,6.31,6.31,0,0,0,.16,1.42A17.74,17.74,0,0,1,5.84,6.76,6.25,6.25,0,0,0,7.77,15.1a6.22,6.22,0,0,1-2.83-.78V14.4a6.25,6.25,0,0,0,5,6.13,6.21,6.21,0,0,1-1.65.22,6.33,6.33,0,0,1-1.18-.11A6.25,6.25,0,0,0,13,25a12.58,12.58,0,0,1-9.25,2.59,17.68,17.68,0,0,0,9.58,2.81c11.49,0,17.77-9.52,17.77-17.77q0-.41,0-0.81A12.72,12.72,0,0,0,34.17,8.55Z"/></svg></a></li>
		
		<li class="social-instagram"><a target="_blank" href="https://www.instagram.com/baptistnews"><svg id="Icon" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 36 35.99"><defs><style>.cls-1{fill:#c2cad1;}</style></defs><title>Instagram</title><path class="cls-1" d="M28.69,3.36H7.08A3.64,3.64,0,0,0,3.44,7V28.87a3.64,3.64,0,0,0,3.64,3.64H28.69a3.64,3.64,0,0,0,3.64-3.64V7A3.64,3.64,0,0,0,28.69,3.36ZM23.83,17.94a6,6,0,1,1-.67-2.73A6,6,0,0,1,23.83,17.94Zm5.25,9.83a1.49,1.49,0,0,1-1.49,1.49H8.32a1.49,1.49,0,0,1-1.49-1.49V15.2H9.29a9,9,0,1,0,17.2,0h2.6V27.77h0Zm0-17.27A1.49,1.49,0,0,1,27.59,12H25.32a1.49,1.49,0,0,1-1.49-1.49V8a1.49,1.49,0,0,1,1-1.41h2.74a1.49,1.49,0,0,1,1.49,1.49V10.5h0Z"/></svg></a></li>

		<!--<li class="social-youtube"><a target="_blank" href="#"><svg id="Icon" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 36 35.99"><defs><style>.cls-1{fill:#c2cad1;}</style></defs><title>YouTube</title><g id="Lozenge"><path class="cls-1" d="M34.53,11.18a7.31,7.31,0,0,0-1.34-3.36A4.84,4.84,0,0,0,29.8,6.39C25.07,6,18,6,18,6h0s-7.1,0-11.83.34A4.84,4.84,0,0,0,2.74,7.82,7.31,7.31,0,0,0,1.4,11.18a51.13,51.13,0,0,0-.34,5.47v2.56a51.13,51.13,0,0,0,.34,5.47A7.31,7.31,0,0,0,2.74,28a5.73,5.73,0,0,0,3.73,1.45C9.18,29.75,18,29.83,18,29.83s7.1,0,11.83-.35A4.84,4.84,0,0,0,33.19,28a7.31,7.31,0,0,0,1.34-3.36,51.19,51.19,0,0,0,.34-5.47V16.65A51.19,51.19,0,0,0,34.53,11.18ZM14.48,22.32v-9.5l9.13,4.77Z"/></g></svg></a></li>-->

		<!-- <li class="social-googleplus"><a target="_blank" href="https://plus.google.com/+ABPnewsUS"><svg id="Icon" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 36 35.99"><defs><style>.cls-1{fill:#c2cad1;}</style></defs><title>Google+</title><path class="cls-1" d="M1.35,21a11.58,11.58,0,0,0,10.78,8.79c8,0.5,12.77-6.65,11.78-13.78H13V20.3h6.3c0,1.66-2.16,3.65-3.82,4.31a8.94,8.94,0,0,1-1.82.5A7.28,7.28,0,0,1,5.83,19a6.93,6.93,0,0,1,5.47-7.8,6.66,6.66,0,0,1,6.14,1.49l3.15-3.15C18.94,7,15.09,6,11.8,6.22A11.91,11.91,0,0,0,1.35,21Zm28.37,0.33V18.16H26.4V16h3.32V12.85h2.16V16H35v2.16H31.87v3.15H29.72Z"/></svg></a></li> -->
		
		<li class="social-linkedin"><a target="_blank" href="https://www.linkedin.com/company/baptist-news-global"><svg id="Icon" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 36 35.99"><defs><style>.cls-1{fill:#c2cad1;}</style></defs><title>LinkedIn</title><path class="cls-1" d="M8.45,5.12A2.44,2.44,0,0,0,5.83,7.65a2.44,2.44,0,0,0,2.59,2.49A2.52,2.52,0,1,0,8.45,5.12ZM6,29h5V12H6V29ZM24.43,12.23c-1.59,0-3.22-.33-5,2.36h-0.1L19.29,12H14.87c0.07,1.41.07,3.52,0.07,5.52V29h5V19.19a3.57,3.57,0,0,1,.2-1.25,2.66,2.66,0,0,1,2.53-1.87c1.81,0,2.53,1.41,2.53,3.48V29h5V18.92C30.18,14.2,27.71,12.23,24.43,12.23Z"/></svg></a></li>
		
		<li class="social-rss"><a target="_blank" href="/feed/"><svg id="Icon" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 36 35.99"><defs><style>.cls-1{fill:#c2cad1;}</style></defs><title>RSS</title><path class="cls-1" d="M5.36,4.61S29.77,3.41,31.7,29.15H26.77s1-18.76-21.41-20.45V4.61Z"/><path class="cls-1" d="M5.36,13.15s14.31-.48,17.08,16H17.51s-0.6-9.74-12.15-11.91V13.15Z"/><path class="cls-1" d="M8,23.88A3.13,3.13,0,1,1,4.91,27,3.13,3.13,0,0,1,8,23.88Z"/></svg></a></li>		
		
	</ul>
	</div></footer></div>		<style type="text/css">
			.ssp-wave wave wave {
				background: #28c0e1 !important;
			}
		</style>
			<div style="display:none">
	</div>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var PT_CV_PUBLIC = {"_prefix":"pt-cv-","page_to_show":"5","_nonce":"cdc6df348b","is_admin":"","is_mobile":"","ajaxurl":"https:\/\/baptistnews.com\/wp-admin\/admin-ajax.php","lang":"","loading_image_src":"data:image\/gif;base64,R0lGODlhDwAPALMPAMrKygwMDJOTkz09PZWVla+vr3p6euTk5M7OzuXl5TMzMwAAAJmZmWZmZszMzP\/\/\/yH\/C05FVFNDQVBFMi4wAwEAAAAh+QQFCgAPACwAAAAADwAPAAAEQvDJaZaZOIcV8iQK8VRX4iTYoAwZ4iCYoAjZ4RxejhVNoT+mRGP4cyF4Pp0N98sBGIBMEMOotl6YZ3S61Bmbkm4mAgAh+QQFCgAPACwAAAAADQANAAAENPDJSRSZeA418itN8QiK8BiLITVsFiyBBIoYqnoewAD4xPw9iY4XLGYSjkQR4UAUD45DLwIAIfkEBQoADwAsAAAAAA8ACQAABC\/wyVlamTi3nSdgwFNdhEJgTJoNyoB9ISYoQmdjiZPcj7EYCAeCF1gEDo4Dz2eIAAAh+QQFCgAPACwCAAAADQANAAAEM\/DJBxiYeLKdX3IJZT1FU0iIg2RNKx3OkZVnZ98ToRD4MyiDnkAh6BkNC0MvsAj0kMpHBAAh+QQFCgAPACwGAAAACQAPAAAEMDC59KpFDll73HkAA2wVY5KgiK5b0RRoI6MuzG6EQqCDMlSGheEhUAgqgUUAFRySIgAh+QQFCgAPACwCAAIADQANAAAEM\/DJKZNLND\/kkKaHc3xk+QAMYDKsiaqmZCxGVjSFFCxB1vwy2oOgIDxuucxAMTAJFAJNBAAh+QQFCgAPACwAAAYADwAJAAAEMNAs86q1yaWwwv2Ig0jUZx3OYa4XoRAfwADXoAwfo1+CIjyFRuEho60aSNYlOPxEAAAh+QQFCgAPACwAAAIADQANAAAENPA9s4y8+IUVcqaWJ4qEQozSoAzoIyhCK2NFU2SJk0hNnyEOhKR2AzAAj4Pj4GE4W0bkJQIAOw==","is_mobile_tablet":"","sf_no_post_found":"No posts found."};
var PT_CV_PAGINATION = {"links":{"page_1":"https:\/\/baptistnews.com\/article\/what-an-open-door-to-asylum-seekers-looks-like\/","page_n":"https:\/\/baptistnews.com\/article\/what-an-open-door-to-asylum-seekers-looks-like\/?_page=_CVNUMBER_"},"first":"\u00ab","prev":"\u2039","next":"\u203a","last":"\u00bb","goto_first":"Go to first page","goto_prev":"Go to previous page","goto_next":"Go to next page","goto_last":"Go to last page","current_page":"Current page is","goto_page":"Go to page"};
/* ]]> */
</script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/content-views-query-and-display-post-page/public/assets/js/cv.js?ver=2.3.1'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/pt-content-views-pro/public/assets/js/cvpro.min.js?ver=5.3.4.3'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2020Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.10'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=3.2.1'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/wp-gallery-custom-links/wp-gallery-custom-links.js?ver=1.1'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/easy-fancybox/js/jquery.fancybox.min.js?ver=1.3.24'></script>
<script type='text/javascript'>
var fb_timeout, fb_opts={'overlayShow':true,'hideOnOverlayClick':true,'overlayOpacity':.25,'overlayColor':'#fff','showCloseButton':true,'margin':20,'centerOnScroll':true,'enableEscapeButton':true,'autoScale':true };
if(typeof easy_fancybox_handler==='undefined'){
var easy_fancybox_handler=function(){
jQuery('.nofancybox,a.wp-block-file__button,a.pin-it-button,a[href*="pinterest.com/pin/create"],a[href*="facebook.com/share"],a[href*="twitter.com/share"]').addClass('nolightbox');
/* IMG */
var fb_IMG_select='a[href*=".jpg"]:not(.nolightbox,li.nolightbox>a),area[href*=".jpg"]:not(.nolightbox),a[href*=".jpeg"]:not(.nolightbox,li.nolightbox>a),area[href*=".jpeg"]:not(.nolightbox),a[href*=".png"]:not(.nolightbox,li.nolightbox>a),area[href*=".png"]:not(.nolightbox),a[href*=".gif"]:not(.nolightbox,li.nolightbox>a),area[href*=".gif"]:not(.nolightbox)';
jQuery(fb_IMG_select).addClass('fancybox image');
var fb_IMG_sections=jQuery('.gallery,.wp-block-gallery,.tiled-gallery,.wp-block-jetpack-tiled-gallery');
fb_IMG_sections.each(function(){jQuery(this).find(fb_IMG_select).attr('rel','gallery-'+fb_IMG_sections.index(this));});
jQuery('a.fancybox,area.fancybox,li.fancybox a').each(function(){jQuery(this).fancybox(jQuery.extend({},fb_opts,{'transitionIn':'elastic','transitionOut':'elastic','opacity':false,'hideOnContentClick':true,'titleShow':true,'titlePosition':'over','titleFromAlt':true,'showNavArrows':true,'enableKeyboardNav':true,'cyclic':false}))});};
jQuery('a.fancybox-close').on('click',function(e){e.preventDefault();jQuery.fancybox.close()});
};
var easy_fancybox_auto=function(){setTimeout(function(){jQuery('#fancybox-auto').trigger('click')},1000);};
jQuery(easy_fancybox_handler);jQuery(document).on('post-load',easy_fancybox_handler);
jQuery(easy_fancybox_auto);
</script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/easy-fancybox/js/jquery.easing.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/easy-fancybox/js/jquery.mousewheel.min.js?ver=3.1.13'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/build/lazy-images/js/lazy-images.min.js?ver=8.2.2'></script>
<script type='text/javascript' src='https://1648o73kablq2rveyn64glm1-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>

<!--     ===== START Dreamgrow Scroll Triggered Box 2.3 =====   -->

<div class="dgd_overlay"></div>

<!--     ===== END OF Dreamgrow Scroll Triggered Box 2.3 =====   -->

<!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){
if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({ groupid: 1, speed: 6000 });
	jQuery('.g-2').gslider({ groupid: 2, speed: 6000 });
	jQuery('.g-3').gslider({ groupid: 3, speed: 9000 });
}
});
</script>
<!-- /AdRotate JS -->

<script type='text/javascript' src='https://stats.wp.com/e-202009.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.2.2',blog:'154972450',post:'117799',tz:'-5',srv:'baptistnews.com'} ]);
	_stq.push([ 'clickTrackerInit', '154972450', '117799' ]);
</script>
		<script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":117799,"object_key":"post","object_type":"post","term_ids":[4]};</script>
		</body></html>
